WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Specifying different WordPress address breaks permalinks (3 posts)

  1. aajax
    Member
    Posted 4 years ago #

    I followed the instructions described within -

    http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory

    and ended up with the so called pretty permalinks to existing posts being broken. I can change back to the default option for permalink structure and regain access to those posts but reverting again to pretty permalinks again results in broken links.

    How do I overcome this problem?

  2. aajax
    Member
    Posted 4 years ago #

    It turns out that I can manually insert the directory name that refers to the location specified by Options>WordPress address and the links work. I've tried configuring Apache2 with both an Alias and a symbolic link in the directory specified for Blog address. This suggests to me that the rewrite rules are messed up. I did pay attention to the rules displayed when updating permalinks and there was no change from what I previously had specified in htaccess.

    Does that provide useful insight? I'm still unable to make it work.

  3. aajax
    Member
    Posted 4 years ago #

    Found it! In the process of setting up Apache2 for the new document root I used a block of code for the Directory directive which contained AllowOverride none, which apparently superseded the AllowOverride all specified for the system root / directory. Insofar as the .htaccess file is now in the new document root it is necessary to allow it to be processed.

Topic Closed

This topic has been closed to new replies.

About this Topic