WordPress.org

Ready to get started?Download WordPress

Forums

WP eCommerce
[resolved] Specials Widget doesn't randomize output (2 posts)

  1. LimeCanvas
    Member
    Posted 1 year ago #

    The file wp-ecommerce/wpsc-widgets/specials_widget.php does not randomize the specials, so always displays the same X items.

    I've added an 'orderby' => 'rand' to the $args array around line 189 in function wpsc_specials

    http://wordpress.org/extend/plugins/wp-e-commerce/

  2. Visser Labs
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Lime Canvas, thanks for the suggestion. What would be ideal is adding a filter option to the Widget Settings for either Latest (default) or Random. I've suggested this for inclusion in a Plugin update.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.