WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Special characters in my database after moving to a new host (3 posts)

  1. su1
    Member
    Posted 3 years ago #

    Hello,

    after moving my site and database to a new host, I got special characters in my database (problem of encoding probably).

    For example instead of "Bébert" I get "Bébert".

    I have opened the exported .sql file and the correct characters are present, so I guess it's a problem during the upload? But my file is encoded in utf8 and I set up PhPMyadmin to upload an utf8 file, so I don't know what's going on.

    Any ideas?

    Thanks.

    Edit: old server version is 5.0.92. New server version is 5.0.91. That's the only difference I've found so far.

  2. su1
    Member
    Posted 3 years ago #

    up please I need your help

  3. su1
    Member
    Posted 3 years ago #

    Problem solved.
    One of the tables in my sql file had the parameter

    DEFAULT CHARSET=latin1 COLLATE=latin1_general_ci;

    all the other tables were in utf8 though.

    Just uploading this latin1 table alone after the others should resolve the problem (if it can help others)

Topic Closed

This topic has been closed to new replies.

About this Topic