WordPress.org

Ready to get started?Download WordPress

Forums

[closed] Span tags being inserted -- WP / Chrome Bug? (6 posts)

  1. paulc
    Member
    Posted 1 year ago #

    A few weeks ago, I noticed that a bunch of span tags were being inserted into my posts, for example: <span style="font-size: 13px; line-height: 19px;">. This started just a few weeks ago.

    Here's the repro case:

    1. create a new post and start typing (i.e., don't paste in text from anywhere
    2. Hit enter to start a new line/paragraph, and continue typing.
    3. Go back to the beginning of the new paragraph, and hit backspace to combine the first and second paragraphs.

    The result is a <span> tag that wraps the text of the former second paragraph.

    I've verified this bug with all plug-ins turned off. I am running Thesis 1.8.4.

    I suspect the issue is due to a Chrome update (I'm running version 24.0.1312.57, which released Jan 30).

    I do NOT have this problem with Internet Explorer 9.

    This looks to be similar/same as the issue posted at http://wordpress.org/support/topic/html-codex-trouble

  2. I am running Thesis 1.8.4.

    Have you also tried switching to the Twenty Twelve theme, clearing your browser cache and cookies, and trying again? Deactivating all of your plugins is a good troubleshooting step but you should also rule out your theme.

  3. Emily Barney
    Member
    Posted 1 year ago #

    A colleague is editing a blog and seeing this same issue, but with different code in the span (it reduces the text size). He was using Chrome but switched to Firefox and it disappeared.

    I checked that WordPress was updated and TinyMCE as well. We tried disabling TinyMCE and that didn't help. None of the other plugins should be affecting the editor interface. We are using a custom child theme for Mystique 3.1.

    Mystique does come with an editor stylesheet. Is there any chance that this could be the source of the trouble with Chrome? I find this whole thing bizarre, personally.

    Note: This is a live website, I can't disable or switch the theme. I haven't seen the problem on my own computer, only on my colleague's (though he's seen it at two different computers) so I'm having trouble confirming it as a general error with any of our installed files. On my computer I have the same Chrome version listed above: 24.0.1312.57

  4. ldekay
    Member
    Posted 10 months ago #

    I've seen the same thing and only with Chrome, so it's obviously a problem with the Chrome/WP (or one of it's plug-ins) combination. Very annoying since inserted '</span><span style="line-height: 1.4em;">' results in line breaks in the Visual page.

    Anyone have a clue how to stop this behavior in Chrome?

  5. Frank Gomez
    Member
    Posted 8 months ago #

    This issue should be resolved ASAP as it is a serious bug! To me it seems that if unwanted, untyped code could appear without a user adding it on purpose it would also be a security risk.

  6. WPyogi
    Volunteer Moderator
    Posted 8 months ago #

    @Frank Gomez - this thread is 8 months old - so not relevant to current version of WP. If you have a current issue, please start your own thread as per:

    http://codex.wordpress.org/Forum_Welcome#Where_To_Post

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags