WordPress.org

Ready to get started?Download WordPress

Forums

Spam links appearing in footer - can't get rid? (10 posts)

  1. dwjoll
    Member
    Posted 2 years ago #

    Spam links are appearing in the footer of my website. This happened on another site of mine and I had to reinstall/delete the database but I don't really want to do that here....

    What's happened? How do I get rid of this?

    Thanks for any help. I'm a bit lost at what to do.

  2. dwjoll
    Member
    Posted 2 years ago #

  3. esmi
    Forum Moderator
    Posted 2 years ago #

  4. dwjoll
    Member
    Posted 2 years ago #

    Hi Esmi,

    I'm taking a look at those now. I'd like to know what's happened though - had my site been hacked? Is this what happens i.e. spam in footer?

  5. esmi
    Forum Moderator
    Posted 2 years ago #

    It looks like some sort of hack, yes. The links I gave above should help if you work through them in order.

  6. dwjoll
    Member
    Posted 2 years ago #

    I've asked a few friends to click my site and they can't see the spam ... it just seems to be my end? Any idea what that may be?

    Can you see the spam?

    the site is http://www.partnersinsoul.com/

  7. dwjoll
    Member
    Posted 2 years ago #

    More testing: Everyone I have asked to check the site they say they can't see the spam (See screenshot)

    I tested on another laptop I have at home (connected to the same router via wireless) and that also has the same problem.

    SO the only way this could be happening to me is by some sort of IP address spam/hack?

  8. esmi
    Forum Moderator
    Posted 2 years ago #

    It's possible that your computer has been infected with adware or a virus of some kind.

  9. adpawl
    Member
    Posted 2 years ago #

    Similar thread
    http://wordpress.org/support/topic/stealth-link-injection?replies=18

    But computer infection is also possible.

  10. dwjoll
    Member
    Posted 2 years ago #

    Thanks for the link adpawl I will have a read through that.

    Did a full virus/malware/spyware scan on both PC and Laptop, both are clean. No problems there.

    I did another test this morning. I made a note of my IP address, went on my site and the spam was there as expected.

    I restarted my router so I could obtain a new IP address. I then went back on to my website and the spam was gone.

    So it's definitely something to do with recognising IP addresses

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags