WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Spam Comments (6 posts)

  1. mtgarden
    Member
    Posted 7 years ago #

    I have recently (last 10-12 days) started getting spam comments on my blog. My blog is almost two years old. I realize, that spam comments are familiar, but have several questions here.

    First, when I moderate a question as spam, what happens? Does it bounce back a request to the originating IP and thus confirm my address in any manner? I ask since the amount of spam has been snowballing. I went from 1-2 spam comments a week ago to 75+ in a half hour. (Fortunately, that load is not sustained.)

    Second, why are the spammers able to post comments without registering a user. I require all first time posters to register and have their first post moderated. It seems that they can bypass this. Any help? I do have the latest update of WP and my provider updates the server OS and Apache on a fairly consistent basis.

    Third, the spammers are only targeting two posts, one of which is quite old. Is their any good way to protect those two posts?

  2. Samuel B
    moderator
    Posted 7 years ago #

    You are getting trackback spam. You can turn trackbacks off but will miss the real benefits of it.
    I assume you have Akismet activated. In addition, install the Bad Behavior plugin and your trackback spam will stop.

    You can "expire" older posts if you choose with this plugin:
    http://wunder-ful.com/wordpress-plugins

  3. RScott
    Member
    Posted 7 years ago #

    I turned off trackback and comments, as suggested here, but am still getting lots of spam "comments." Can anyone explain how to stop this? They spam not only the blog, but also my email with notifications (double spam).

    And it's getting worse by the day.

  4. obscure
    Member
    Posted 7 years ago #

    Did you install Bad Behaviour plugin as suggested?

  5. mtgarden
    Member
    Posted 7 years ago #

    Sorry, for the slow response. I wanted to test the plugins to verify that they had worked. They did function. Thank you for your help.

  6. geoffe
    Member
    Posted 7 years ago #

    RScott, when you disable ping/trackbacks it only sets the default for future posts, yet you need to fix your current posts.

    To do that, you could use this query in phpmyadmin to disable all trackbacks and pingbacks:
    Update wp2_posts set ping_status="closed"

    This will disable trackbacks on all posts. I had the same trouble as you, did this and problem solved.

Topic Closed

This topic has been closed to new replies.

About this Topic