WordPress.org

Ready to get started?Download WordPress

Forums

Space / linefeeds in RSS -> broken feeds (7 posts)

  1. TheMarco
    Member
    Posted 8 years ago #

    Hi all... on our new WP 2.0.2 site all feeds are broken. It seems something is inserting a space before the xml header. I never touched the feed code so I don't understand this.

    Example:

    http://dutchdirections.nl/feed

    Anyone know how I fix this?

  2. TheMarco
    Member
    Posted 8 years ago #

    Anyone? :(

  3. ebrito
    Member
    Posted 8 years ago #

    Your feed seems to be ok. How have you solved the problem?

    My feed has a similar problem: inserts a blank row at the beginning.

    http://enrique.brito.es/blog/feed

  4. ebrito
    Member
    Posted 8 years ago #

    This is how I have solved my problem in WP 1.5.1.2:

    I have edited ALL wp files in ALL directories to delete empty lines at the end of some files.

    Hard work.

  5. SteveMunro2
    Member
    Posted 8 years ago #

    I too have the same problem described by TheMarco. All of my XML headers (for feeds and for regular pages) have a leading space. For the pages, it doesn't seem to bother the browsers, but for feeds, it's another story.

    Where is this extra space coming from? It appears on regular site pages as well as on the admin dashboard, and so it's not specific to the theme files.

    I am running version 2.0. Is this fixed in 2.0.2, or can I selectively apply a patch to correct the problem without going through the upgrade right away?

  6. Chris_K
    Member
    Posted 8 years ago #

    To follow up with what ebrito suggests... go through your plugins source files (/wp-content/plugins) and ensure that there are no trailing lines at the end of them.

    Or, disable plugins and then re-enable one by one until you can spot the one causing grief.

    If you're viewing your feed in a browser, be sure to empty the browser cache in between each viewing (or use ctrl-F5).

  7. SteveMunro2
    Member
    Posted 8 years ago #

    It turns out that there was a trailing blank in the Email Anonymizer plugin. Got rid of it. Problem gone.

    Many thanks.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags