WordPress.org

Ready to get started?Download WordPress

Forums

SendPress Newsletters
[resolved] SP Hangs When Sending Emails (3 posts)

  1. hsfcwebmaster
    Member
    Posted 4 months ago #

    I'm attempting to send slightly less than 100 emails per batch less than once a week. The send process hangs after sending approximately 35 - 37 emails. I click 'Close' on the window and my site crashes and in unavailable for several seconds. I then have to repeat the process 2 - 3 more times to complete sending all of the queued emails.

    GoDaddy is the hosting provider and the Godaddy checkbox is checked on the Settings > Sending page.

    Thank you!

    Multi-site: No
    SP Version: 0.9.9.5
    WordPress Version: 3.8.1
    Sending Method: SendPress_Sender_Website
    SendPress Tables: Tables Installed

    PHP Version: 5.3.24
    MySQL Version: 5.0.96-log
    Web Server Info: Apache
    PHP Memory Limit: 256M
    PHP Post Max Size: 33M
    PHP Memory Used: 17.97 MByte

    WP Memory Limit: 40MB
    WP_DEBUG: Disabled

    UPLOAD_MAX_FILESIZE: 32MB
    POST_MAX_SIZE: 33MB
    DISPLAY ERRORS: On (1)
    FSOCKOPEN: Your server supports fsockopen.

    Platform: Windows
    Browser Name: Mozilla
    Browser Version: 5.0
    User Agent String: Mozilla/5.0 (Windows NT 6.1; WOW
    64; Trident/7.0; rv:11.0) like Gecko

    ACTIVE PLUGINS:

    Google Calendar Widget: 1.3.2
    My Page Order: 3.3.2
    SendPress Newsletters: 0.9.9.5

    CURRENT THEME:

    2010 Weaver: 1.5.4

    https://wordpress.org/plugins/sendpress/

  2. itdoug
    Member
    Plugin Author

    Posted 4 months ago #

    Thanks for providing the support information in the ticket. I do have ideas as to what might be the problem, but let me first start by letting you know that you you're to be on Go Daddy's older servers. You can tell by the fact that you were running such an old version of MySQL. You may want to ask them to upgrade you to a newer server.

    In order to solve your current problem, I believe you need to do one or both of the following.

    Request that Go Daddy allow you to increase the memory allocated to WordPress. Currently it is set at 40 MB, which is very very low. There may be a configuration in your WordPress config file that will allow you to do that yourself, but they may have also set it in a way you can't change it without opening a support request.

    The other thing you should try is going to settings and then the advanced tab. On that tab you'll find some advance settings for changing how many messages are sent per cron execution. The default was 25. If your site is having problems with the default, you could try lowering that number. You should also enable auto cron and not click send emails now, which will smooth out the sending.

    https://sendpress.com/support/knowledgebase/sendpress-auto-cron/

  3. hsfcwebmaster
    Member
    Posted 4 months ago #

    itdoug... Thank you very much for the reply. I increased the WP memory to 128MB in wp-config.php. I'll also experiment with the auto cron option; that sounds like a perfect solution. Thanks again!

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.