WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] SOS: Can't select database (9 posts)

  1. collenice
    Member
    Posted 5 years ago #

    Hi guys, I am having a problem regarding the installation and the 5-min guide has taken me more than 5 days and still no positive result coming out.

    My whole files seem installed correctly and opening txt file worked ok. When I tried to open the install.php file with "http://huangg.com/wordpress/wp-admin/install.php" (I don't put it under root directory), it shows the following message,

    QUOTE:
    < Can’t select database

    We were able to connect to the database server (which means your username and password is okay) but not able to select the huangg.com database.

    * Are you sure it exists?
    * Does the user huangg_com have permission to use the huangg.com database?
    * On some systems the name of your database is prefixed with your username, so it would be like username_huangg.com. Could that be the problem? >

    Anyone knows where my problem lies? I REALLY REALLY appreciate it!

  2. jabecker
    Member
    Posted 5 years ago #

    It sounds like either you have not created a database or your wp-config file is not set up correctly.

    Look at the detailed install instructions here: http://codex.wordpress.org/Installing_WordPress, especially steps 2 and 3.

  3. krembo99
    Member
    Posted 5 years ago #

    also do check that your DB is MySql and not SQL or MSQL

  4. collenice
    Member
    Posted 5 years ago #

    Hi I used http://www.myhosting.com service and have called them for 10+ times, the representative said the MYSQL database is set up and everything is set up. The info they provided will be put in the wp-config file right? If it is the case, I am 100% sure the info they sent to me are exactly in the wp-config file.

    Everything is installed correctly but it just didn't work. I observed there are some others having the same problem. One solved it by adding the database and etc. But my host said the database is installed, meaning the info in the wp-config file would be ok.

    What kind of settings should I do? Thanks in advance.

  5. collenice
    Member
    Posted 5 years ago #

    http://wordpress.org/support/topic/218313?replies=28

    Here is another thread, but it seems the problem has not resolved or the answer was not posted out here, sadly.

    http://wordpress.org/support/topic/181545?replies=5

    This post solves the problem but what's the meaning of our moderator's words? QUOTE - Sounds like a problem in you hosting interface. Might talk to your host and tell them you've had no luck assigning a user with the proper privileges to the database. -- Anyone knows?

    Thanks

  6. collenice
    Member
    Posted 5 years ago #

    Anyone could help? Cheers...

  7. Samuel B
    moderator
    Posted 5 years ago #

    "your hosting interface" means (in this context) the user is being assigned to the database but does not have ALL privileges - meaning the host interface isn't working correctly to assign these privileges - this is rare but does happen.

    for your database name huangg.com
    I am not saying it isn't possible but very seldom would this be the name of the database - and that is the error in your op.

  8. collenice
    Member
    Posted 5 years ago #

    Thanks a lot. I changed to bluehost and the problem solved.

  9. nuways
    Member
    Posted 4 years ago #

    I had the same problem with "Can't select database" as well....

    Turns out, I had to figure out how to get into my MySQL control panel....also known as cpanel.

    I contacted my hosting provider (webhostgiant) through online tech support and they gave me the special URL I needed to get into my cpanel.

    Once there, I created a database in the MySQL database. And just like other users on this forum have noted, it created a naming structure by default that was

    username_dbname

    Once I did that, everything worked perfectly.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.