WordPress.org

Ready to get started?Download WordPress

Forums

Wp-Pro-Quiz
"Sorting' and "Matrix Sorting" Choices not working! (5 posts)

  1. ziadjbt78
    Member
    Posted 10 months ago #

    Hello,

    The plugin is perfectly working for me but I am facing issues in only two answering types:

    1. "Sorting"
    2. "Matrix Sorting"

    The "Start Quiz" button becomes non-clicakble and I just can't progress further when any or both of the above types are created in the quiz regardless if the quiz is made of only the two above types or a combination of multiple types...

    All other answering types are working great but I am only facing an issue with the two above modes.

    Any help would be extremely appreciated.

    Thanks!
    Ziad

    http://wordpress.org/plugins/wp-pro-quiz/

  2. xeno010
    Member
    Plugin Author

    Posted 10 months ago #

    Hello ziadjbt78,

    Do you have a weblink to a test quiz?

    For me it works perfectly: http://www.it-gecko.de/wp-pro-quiz-quiz-plugin-fuer-wordpress.html

  3. ziadjbt78
    Member
    Posted 10 months ago #

    Hello Xeno010,

    Thanks for your prompt reply.

    Please find below the weblink as requested for the test quiz:

    http://www.cia.info/quizzes/

    Kindly investigate from your end and I would extremely appreciate if you can get back to me with a solution to this.

    Thanks so much.
    Ziad

  4. xeno010
    Member
    Plugin Author

    Posted 10 months ago #

    Hello ziadjbt78,

    I have found the error (your themes).

    Your "jquery-ui" integration is wrong

    Solution:

    Edit "scripts.php" file in "wp-content/themes/AskIt/epanel/page_templates/includes/"

    replace:

    <script type="text/javascript" src="http://ajax.googleapis.com/ajax/libs/jqueryui/1.7.1/jquery-ui.min.js"></script>

    with:

    <!--<script type="text/javascript" src="http://ajax.googleapis.com/ajax/libs/jqueryui/1.7.1/jquery-ui.min.js"></script>-->

    Edit "functions.php" file in "wp-content/themes/AskIt/epanel/page_templates/"

    replace (last line) :

    } ?>

    with:

    } 
    
    function at_correct_include_js() {
    	wp_enqueue_script(
    		'jquery-ui-tabs',
    		false,
    		array( 'jquery' ),
    		false,
    		true
    	);
    }
    add_action( 'wp_enqueue_scripts', 'at_correct_include_js' );
    
    ?>

    try again

    xeno010

  5. ziadjbt78
    Member
    Posted 10 months ago #

    Hello my friend,

    I am not sure I was able to locate the same files as the ones you have stated above.

    However I have found the same codes but in other locations.

    For example for the first code replacement that you referred to I have found the file in here:

    wp-content/themes/AskIt/includes/scripts.php

    And for the second code replacement I have found it in here:

    "wp-content/themes/AskIt/epanel/core_functions.php

    Are those the two files that you meant I need to replace the codes in because I have reflected the changes in them and indeed your plugin is now working perfectly fine!

    My only concern is that if those are the files that I should have changed and it wont affect the other functionality of my site because the files names and locations are little bit different from what you mentioned in your message?

    Please confirm.

    Thanks!

    Ziad

Reply

You must log in to post.

About this Plugin

About this Topic