WordPress.org

Ready to get started?Download WordPress

Forums

WP-Filebase Download Manager
[resolved] Sort by file_date in list not working (6 posts)

  1. James
    Member
    Posted 1 year ago #

    [wpfilebase tag=list id=2 tpl=data-table sort='>file_date' /]

    is not working it always shows up as sorted by file_name.

    Please advise! Thanks

    http://aviahosting.com/woodlandsassn.org/woodlands-monthly-newsletters/

    http://wordpress.org/extend/plugins/wp-filebase/

  2. Fabian
    Member
    Plugin Author

    Posted 1 year ago #

    DataTables use its own sorting mechanism, so the shortcode argument is ignored.
    See the DataTables Documentation to setup sorting:
    http://datatables.net/plug-ins/sorting

  3. James
    Member
    Posted 1 year ago #

    Ok...Any guidance on where to add the following to make this work? BTW this should be added as a feature IMO, a setting "choose sorting column for data table" and whether "asc or desc".

    Thanks

    "aaSorting": [[ 2, "desc" ]]

  4. James
    Member
    Posted 1 year ago #

    NM I changed to a different plugin. thanks anyway.

  5. manyk
    Member
    Posted 10 months ago #

    You may use this trick to solve your sorting problem:

    In WP-Filebase change your template and add one more colum containing the field you want to sort by - file_date - then hide it with style:
    <td style="display:none;">

    Now you may use this column to sort by.

  6. bszen27
    Member
    Posted 10 months ago #

    The problem with sorting by file_date is that it doesn't actually sort by chronological date, but rather alphabetically by day/month name. I was blown away by this! That must be a bug, unless I am missing something.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.