WordPress.org

Ready to get started?Download WordPress

Forums

Sorry, you need to enable sending referrers for this feature to work. (16 posts)

  1. bagiu
    Member
    Posted 7 years ago #

    The title is frustrating because I have seen it in the forums, however I have not found my answer. I have no firewalls, no anti-virus, no browser blocks. I had a blank shell of a template ready to receive my tweaks from my wp-admin site, made them in the options, clicked "update" and with that I am not able to access my site, my template is gone, just text and I can't get it back to the way it was.

    I am completely green. It took me ALL F*ING DAY to get to where it was when I screwed it up by changing my options. Can anyone help me or am I going to be a Typepad slave forever?

  2. Samuel B
    moderator
    Posted 7 years ago #

  3. DanBollinger
    Member
    Posted 7 years ago #

    I too made some changes on a custom page, and later on a WP Page, and got the same error both times even though Sending Referrers was enabled.

    The problem isn't in our browsers (after all, we've both been using WP-Admin all along) but with the code we are writing. I just wish I knew what I'm doing or not doing.

  4. bagiu
    Member
    Posted 7 years ago #

    > Maybe this helps?
    > codex.wordpress.org/Enable_Sending_Referrers

    Believe it or not that error message I am getting refers me to that page ;) I have been to that page, checked and rechecked ALL the browsers on my machine to see they are set properly. As I stated, I am not using any firewalls, do not have antivirus software (oh living dangerously). So what is my issue?

  5. Samuel B
    moderator
    Posted 7 years ago #

    "The problem isn't in our browsers (after all, we've both been using WP-Admin all along) but with the code we are writing. I just wish I knew what I'm doing or not doing."

    perhaps post your code at:
    http://paste.uni.cc
    and let's look at it?
    Post back with uri to code.

  6. DanBollinger
    Member
    Posted 7 years ago #

  7. DanBollinger
    Member
    Posted 7 years ago #

    The other error I am getting is 'file not found' it is looking for the post.php file.

  8. Samuel B
    moderator
    Posted 7 years ago #

    Hi,
    I'm off to work now. If no one has helped you, I will get on this after work.

  9. DanBollinger
    Member
    Posted 7 years ago #

    Thanks!

  10. bagiu
    Member
    Posted 7 years ago #

    I followed the instructions here: http://wordpress.org/support/topic/66997?replies=9 and changed my site url (that was *my* issue as I'd changed it in my WP Options). Then I got a page that said I'd had WP already installed, then I dropped mySQL tables and voila. Starting all over and now terrified of my Options tab. Not bad for 12 hours of wasted time at the computer ;)

  11. Samuel B
    moderator
    Posted 7 years ago #

    Dan - I don't find anything wrong on visual inspection or direct comparison with another file of same.
    Does bagiu have a point?
    Anyway, I'll make a try of it on a test blog and see what happens.

  12. Samuel B
    moderator
    Posted 7 years ago #

    Dan,
    Here's what I got when I dropped the code straight into a page:
    http://www.comeuphither.com/blog/test/

  13. DanBollinger
    Member
    Posted 7 years ago #

    Sam, That's what I get, too. If you hit submit you'll get the 'enable sending referrers' error. I was hoping to create a Page that incorporated the Post feature without users having to leave my blog site and enter the WP-Admin site.

    After all, they can make comments from the blog, why not make draft Posts, too?

    Any ideas? I'll start a new item about a Post page and see what happens there. Dan

  14. DanBollinger
    Member
    Posted 7 years ago #

  15. cal03isle
    Member
    Posted 7 years ago #

    Re: Enable sending referrer message. I had the same problem, and found all the fixes had no effect. I went into my MySQL tables and found the www. omitted. The address was listed http://calendarislanddesign.com instead or the http://www.calendarislanddesign.com. Strange the installation would do that. Hope that helps.

  16. vanchan
    Member
    Posted 7 years ago #

    it looks like the problem has been solved with the release of WordPress 2.0.3 in which the referrer check has been removed all together... hurray! (?)

Topic Closed

This topic has been closed to new replies.

About this Topic