WordPress.org

Ready to get started?Download WordPress

Forums

"Sorry, you need to enable sending referrers, for (21 posts)

  1. Anonymous
    Unregistered
    Posted 10 years ago #

    This is the error I get when I try to do anything that attempts to write or delete. I tried to delete entries or make changes to plugins (activate/deactivate), but it would simply take me to this white screen w/ this message.
    Before installing 1.2Final from 1.2Beta, everythign worked like a charm, so anyone have any idea as to what's going on?!
    Thank you very much, everyone.
    site = lame.phatchicks.com

  2. bloodylamer
    Member
    Posted 10 years ago #

    the full error is:
    "Sorry, you need to enable sending referrers, for this feature to work."

  3. rpeeck
    Member
    Posted 10 years ago #

    open up your firewall and turn off "privacy settings" or allow referrers.

  4. OperaManiac
    Member
    Posted 10 years ago #

    i have referrers blocked in opera and this new Security feature is a pita.

  5. bloodylamer
    Member
    Posted 10 years ago #

    Now, I've started to get this error in the "post preview" section when I go to enter a new post.
    anyone seen anything like it?
    Post Preview (updated when post is saved)
    Filed under:
    Database error: [You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 3]
    SELECT category_id, cat_name, category_nicename, category_description, category_parent FROM wp_categories, wp_post2cat WHERE wp_post2cat.category_id = cat_ID AND wp_post2cat.post_id =
    Warning: Invalid argument supplied for foreach() in /fpress/wp-includes/template-functions-category.php on line 90
    � site admin @
    Very odd. pre 1.2 upgrade from 1.2 beta, there was no such error.

  6. Millennium
    Member
    Posted 10 years ago #

    This is, unfortunately, a major area where privacy and security clash. Referers are by no means foolproof, but they are an important first line of defense in many Web apps. Weblogs and web boards are one example, but they are also important for image scripts which attempt to disallow remote linking. However, there are legitimate potential privacy issues with allowing a site to figure out what site its clients are coming from. The debate seems endless, and probably will be.
    What I think really needs to happen is that referers should be blocked if the referer is in a different domain than the destination. That would preserve privacy -information that someone goes from one page on a site to another page on the same site is hardly a privacy violation- while allowing the security of referer-validation for Web apps which need it. Unfortunately, no browser or firewall that I know of allows this feature. Until then, I allow the sending of referers but carefully look at links before I click them; if I suspect that I do not want that kind of relationship drawn I will copy/paste the link URL rather than clicking on it, thus neatly sidestepping the referer issue.
    This may be something you should consider too.

  7. turtelina
    Member
    Posted 10 years ago #

    Sorry for the dumb question, but how and where do you enable referrers in Firefox? I have been looking over and over again, I cannot find it. *blush*

  8. Anonymous
    Unregistered
    Posted 10 years ago #

    install the quick prefs extension from http://texturizer.net/firefox/index.html

  9. OperaManiac
    Member
    Posted 10 years ago #

    he was perhaps asking abt enabling which is ofcourse on by default :)
    turtelina, check ur firewalls or antiviruses for a similar setting.

  10. Madsen
    Member
    Posted 9 years ago #

    someone posted this a while back:
    The solution is to edit wp-admin/admin-functions.php
    on line 369/370 you have a function
    function check_admin_referer()
    I changed that to
    function check_admin_referer() {
    $adminurl = strtolower(get_settings(’siteurl’)).’/wp-admin’;
    $referer = strtolower($_SERVER[’HTTP_REFERER’]);
    if ( !strstr($referer, $adminurl) ) {
    //die(’Sorry, you need to enable sending referrers, for this feature to work.’);
    $referer = “localhost";
    }
    }

  11. Anonymous
    Unregistered
    Posted 9 years ago #

    I encountered the "must enable referers" error when my site was set up with a siteurl that started with "http://" but i was doing some admin stuff with SSL and the url was "https://".
    This makes it complain about the referer not matching.
    Here is a work-around for this problem that still preserves the normal referer checking:
    function check_admin_referer() {
    # don't worry if one of them is https and the other is just http
    $adminurl = strtolower(get_settings('siteurl')).'/wp-admin';
    preg_match("/^https?:\/\/(.*)/", $adminurl, $matches);
    $adminurl = $matches[1];
    $referer = strtolower($_SERVER['HTTP_REFERER']);
    preg_match("/^https?:\/\/(.*)/", $referer, $matches);
    $referer = $matches[1];
    if ( !strstr($referer, $adminurl) ) {
    die('Sorry, you need to enable sending referrers, for this feature to work.');
    }
    }

  12. iamtheenfedel
    Member
    Posted 9 years ago #

    Hey what is up... changing the code on line 371 worked for me but I get a new error about not being able to edit the headers. I simple click the go back button then click the manage links button and all of the changes are there. But it is really annoying having to do that. Do any of you guys know how to fix that problem? The error that I am getting is this:
    Warning: Division by zero in /allenstafford/wp-admin/admin-functions.php on line 371
    Warning: Cannot modify header information - headers already sent by (output started at /allenstafford/wp-admin/admin-functions.php:371) in /allenstafford/wp-admin/link-manager.php on line 269
    Warning: Cannot modify header information - headers already sent by (output started at /allenstafford/wp-admin/admin-functions.php:371) in /allenstafford/wp-admin/link-manager.php on line 270

  13. Anonymous
    Unregistered
    Posted 9 years ago #

    Um...but what if you *don't* have the option of configuring referrers? I sometimes update my blog from work...and if firewalls are truly the culprit, I don't have any way to fix this probelm, short of disabling it. :P Perhaps another solution is in order?

  14. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Check that you can receive cookies in your browser too.

  15. paulvk
    Member
    Posted 9 years ago #

    Same problem, fixed it by disabling Privacy Control, all of the other settings were OK on browser, etc. pvk

  16. paulvk
    Member
    Posted 9 years ago #

    oops, forgot to include I'm using NIS 2004 pro

  17. Anonymous
    Unregistered
    Posted 9 years ago #

    To the guy with the SSL hack. Thank you thank you thank you!!!

  18. AVTMX
    Member
    Posted 9 years ago #

    I second that!!!!!
    To the guy with the SSL hack. Thank you thank you thank you!!!

  19. shuai
    Member
    Posted 9 years ago #

    Can anyone help me the sending reffers is really bugging me. I TURN OFF all firewalls and it doesn't work, in IE or FFX.

    Why is this?

    Can I get to work?

  20. guht
    Member
    Posted 9 years ago #

    I encountered this problem just recently and I tried every solution I could find, and nothing worked.

    I added a little code to help me debug what was actually going on and upon comparing the admin & referer urls. Upon comparing them I noticed that they were different - and then the light bulb went on upstairs.

    I am using a dynamic dns forwarding service, because my ISP blocks port 80. The actual url is different, and yours may be also. I was trying to use http://www.foo.com as the siteurl in the config file, and I actually needed to be using www2.foo.com:6000 - the 6000 is the port Im forwarding http requests to.

    Hope that helps some people.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.