WordPress.org

Ready to get started?Download WordPress

Forums

Sorry, no posts matched your criteria (8 posts)

  1. tblob
    Member
    Posted 9 years ago #

    Hi. If the admin has set the number of blog posts to display on the main page [Options --> Reading --> Show the most recent x y] to be 0, the main page displays, "Sorry, no posts matched your criteria.". Would it be better for WordPress to not display this message? It seems wrong for a user to be given this message when they haven't entered any criteria.

  2. Jinsan
    Member
    Posted 9 years ago #

    Semantics, but, don't you think that the number of posts if 0 would therefore be regarded as no posts - therefore if anyone made a search, the result would be there are no posts that match the criteria. The result is actually true.

    I think you can edit the message, however, but I don't know where

  3. tblob
    Member
    Posted 9 years ago #

    The message makes sense if the user entered a search and there were no results. But the message makes little sense when the user shows up at the web site and is immediately presented with this message, without having typed in any search. The latter is what happens when the admin options are set as I described.

  4. James
    Happiness Engineer
    Posted 9 years ago #

    Why would you want zero posts displayed on your blog's front page?

  5. Jinsan
    Member
    Posted 9 years ago #

    ah that's different then - if the user just enters the page and the search criteria is offered as 0 then that's different - bu as macmanx asks, why is is set to 0? wouldn't it be better to just remove it completely?

  6. tblob
    Member
    Posted 9 years ago #

    Either the value 0 should work for that setting, or it should be disallowed, no?
    I want to display 0 blogs on that page because I want to access the blogs differently than the default method of displaying blogs on the main page. I want to display each user's blog on a separate page.

  7. KyleGM
    Member
    Posted 9 years ago #

    I have used a static index.php and then edited .htaccess to point the permalinks to 'view.php', same file as index.php but with The Loop.

  8. James
    Happiness Engineer
    Posted 9 years ago #

    Just delete "The Loop" from index.php

    http://codex.wordpress.org/The_Loop

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.