WordPress.org

Ready to get started?Download WordPress

Forums

Something isn't right, please help me out? (17 posts)

  1. the-wick
    Member
    Posted 8 years ago #

    Hey, I'm trying to intergrate my WP blog into my site, I followed Moshu's tutorial word for word, but this is what I got
    Why are there weird things covering the sides of my page?
    Also, how can I get rid of the WP header, so that just the entries show on the page? I'm trying to use it as a "news update" tool.
    Thanks so much!!

  2. lustrare
    Member
    Posted 8 years ago #

    Well...your images in the sidebar arent really images. You need to upload them onto your site and edit the file that specifies those images...right now, youre running them from your computer, not your webspace...

  3. the-wick
    Member
    Posted 8 years ago #

    no,they exist on the server. The page is tables based, and the background image is the same as on the header of my page. For some reason, the WP sidebars are overriding my tables. I'm very confused.

  4. spencerp
    Member
    Posted 8 years ago #

    I know you're new, but don't keep posting or double posting this. Because you have one here as well:

    http://wordpress.org/support/topic/58691?replies=12

    Just bump up the original one...with something like: "any more comments"?

    spencerp

  5. spencerp
    Member
    Posted 8 years ago #

    Moshu, must not be around for a little bit or something, because he hasn't replied to anyone's replies lately.. Podz might be able to help ya better on that issue, or someone else..

    spencerp

  6. Glo
    Member
    Posted 8 years ago #

    You just need to edit the css in your wp-content/Themes/classic directory - style.css. Look for #menu and move the sidebar down by the px height of your header. Use margin-top: 50px; or whatever the height is in px.

    It would have been much easier to incorporate your design into WP's table-less design and it would have functioned far better. As it is, you have two separate style sheets competing with each other.

  7. the-wick
    Member
    Posted 8 years ago #

    Glo: are you telling me I need to use the WP style sheet on my website instead of the one I wrote? I'm pretty confused. Thanks for the help with the side bar info!!

  8. the-wick
    Member
    Posted 8 years ago #

    I pretty much need someone to hold my hand, I am very beginner when it comes to this. I have been scouring my code for several hours, and I just don't have the knowledge to see what is wrong, and how it needs to be changed. I'm being told that I have two Style sheets, but I'm obviously very confused, and I don't see where I have two style sheets in the header.php file

  9. spencerp
    Member
    Posted 8 years ago #

    We'll get this for ya, just hoooooLLLDD on!! LOL!! Gotta bitch at the site admins a minute.....

    spencerp

  10. katie1
    Member
    Posted 8 years ago #

    I think we understand that you are new, and that you're having some difficulty trying to understand and sort out your problems. We have, at one stage or another, been were you are now.

    However, you need to also read every reply you receive on issues you post very, very carefully.

    Your biggest problem right now is the fact that your main page (index.php, probably) is calling TWO SETS of header information in your page.

    You have TWO sets of <html> opening statements, as well as two sets of <body> tags which I pointed out in this thread you started on the same problem:
    http://wordpress.org/support/topic/58691?replies=12

    You need to clean up your template files. Check everything carefully, and slowly and you'll probably find that nearly all your problems will disappear. You also need to validate your modifications as you go along, particularly after major design/theme changes.

    And yes, your index.php is calling two sets of style sheets because you have two sets of header information in your file. Delete one immediately.

    For clarity, I used your name URL for viewing of said website.

  11. the-wick
    Member
    Posted 8 years ago #

    I know this is probably super frustrating for those who know what they are doing, but I HAVE read all the comments,and I have spent hours scouring my code to figure out what you are talking about. I have also validated the page, and that didn't help the problem. This is the code, as I am seeing it in my editor, maybe I'm a complete moron, but I don't see two sets of header information or two style sheets:

    <?php

    require('./blog/wp-blog-header.php');

    ?><html>
    <head>
    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
    <title>LIT BY THE 'WICK: all bushwick, all the time</title>

    <link rel="stylesheet" type="text/css" href="http://the-wick.com/blog/wp-content/themes/classic/style.css">
    </head>

    <body background="images/bg2.gif">

    <center>

    <!--- header begins here --->
    <table width="800" border="0" cellspacing="0" cellpadding="0">

    <tr>
    <td><img src="images/header.jpg" width="800" height="250"></td>
    </tr>
    </table>
    <!--- header ends here --->

    <!--- menu begins here --->
    <table border=0 cellpadding=0 cellspacing=0 bgcolor="#2B2426" width=800>
    <tr>
    <td width="67">Home</td>
    <td width="21"><img src="images/space.gif" width=8></td>
    <td width="52">Events</td>
    <td width="21"><img src="images/space.gif" width=8></td>
    <td width="38">Art</td>
    <td width="21"><img src="images/space.gif" width=8></td>
    <td width="91">Restaurants & Bars</td>
    <td width="21"><img src="images/space.gif" width=8></td>
    <td width="33">more</td>
    <td width="21"><img src="images/space.gif" width=8></td>
    <td width="64">more</td>
    <td width="21"><img src="images/space.gif" width=8></td>
    <td width="118">more</td>

    </tr></table>
    <!--- menu ends here --->

    <!--- Left Column starts here --->
    <table width="800" border="0" cellspacing="0" cellpadding="0">
    <tr>

    <td colspan="20%" bgcolor="#46201D"><img src="images/space.gif" width=143 height=80><br>
    <img src="images/space.gif" height=8><br>
    <img src="images/space.gif" width=143 height=80><br>
    <img src="images/space.gif" height=8><br>
    <img src="images/space.gif" width=143><br>
    <img src="images/space.gif" height=8><br>
    <img src="images/space.gif" width=143 height=80><br>
    <img src="images/space.gif" height=8><br></td>
    <!--- left column end here --->

    <!--- middle column starts here --->
    <td colspan="60%"><div id="update">
    <?php define('WP_USE_THEMES', false); get_header(); ?>

    <?php if (have_posts()) : while (have_posts()) : the_post(); ?>

    <?php the_date('','<h2>','</h2>'); ?>

    <div class="post">
    <h3 class="storytitle" id="post-<?php the_ID(); ?>">" rel="bookmark"><?php the_title(); ?></h3>
    <div class="meta"><?php _e("Filed under:"); ?> <?php the_category(',') ?> — <?php the_author() ?> @ <?php the_time() ?> <?php edit_post_link(__('Edit This')); ?></div>

    <div class="storycontent">
    <?php the_content(__('(more...)')); ?>
    </div>

    <div class="feedback">
    <?php wp_link_pages(); ?>
    <?php comments_popup_link(__('Comments (0)'), __('Comments (1)'), __('Comments (%)')); ?>
    </div>

    <!--
    <?php trackback_rdf(); ?>
    -->

    </div>

    <?php comments_template(); // Get wp-comments.php template ?>

    <?php endwhile; else: ?>
    <?php _e('Sorry, no posts matched your criteria.'); ?>
    <?php endif; ?>

    <?php posts_nav_link(' — ', __('« Previous Page'), __('Next Page »')); ?>

    <?php get_footer(); ?>
    </div></div></td>
    <!--- middle column ends here --->

    <!--- right column starts here --->
    <td colspan="20%" bgcolor="#46201D">
    <img src="images/space.gif" width=143 height=80><br>
    <img src="images/space.gif" height=8><br>
    <img src="images/space.gif" width=143 height=80><br>
    <img src="images/space.gif" height=8><br>
    <img src="images/space.gif" width=143><br>
    <img src="images/space.gif" height=8><br>
    <img src="images/space.gif" width=143 height=80><br>
    <img src="images/space.gif" height=8><br>
    </td>
    <!--- right column ends here --->
    </tr>
    </table></center>

    </body>
    </html>

  12. katie1
    Member
    Posted 8 years ago #

    OK. I have just reviewed your site, and I can see now that you have since removed something from your 'home page', I say that loosely, and probably with the removal the duplicate header information also.

    When I last looked, which was just prior to my last reply, the duplication was still occuring most evidently in your <!--midddle column--> section.

    From the code you now provide, see:

    <?php define('WP_USE_THEMES', false); get_header(); ?>

    This shouldn't be in your post section. Try removing it and putting it in your header section.

    -----

    PS: You are not a moron, you're just new to this game. No one is frustrated, or indeed annoyed. We are just trying to help you, but sometimes it's difficult to express that without injuring feelings over the Net. Yes?

  13. the-wick
    Member
    Posted 8 years ago #

    Thanks Katie1.
    I moved the code you suggested to the header section, and now it looks like this which is not what I'm after at all. If you look here, what I'm after is to get the blog entries in the middle section, with no WP header, basically just the ability to see the text of the entry and be able to respond to it.
    I really wish I knew more about this coding method so I can fix it myself. It seems like it should be insanely simple, but I just don't have the knowledge to figure it out.
    Any more suggestions?

  14. the-wick
    Member
    Posted 8 years ago #

    ok, I've fixed the side menu issues, and I think I have it where I want it. One more question: Are the grey stripes on the left and right because of the way the background is configured in the style sheets?

  15. vkaryl
    Member
    Posted 8 years ago #

    No, they're because the stupid "default" theme is built on graphics. So if you want them something else, you'll have to change the graphics.

  16. spencerp
    Member
    Posted 8 years ago #

    LMAO!!@vkaryl's comment.. =) You're still using the "classic" theme for WP, try using the "default" one, once. And edit that and go from there.. Or something..

    http://www.the-wick.com/index2.php

    Just edit either one of those css files...with what you're using for your main site. So the posts and margins are evenly displayed .....

    In the link I posted above, it seems to be almost there, just need to use your own codes to blend it to the main site, and just tweak the margins or paddings on the posts and such, you're getting closer! =)

    spencerp

    Or maybe I'm just getting drunker and missed something...I'm not sure. <sips more beer>..mmm this is good....

  17. Glo
    Member
    Posted 8 years ago #

    the-wick, if you're still having problems, email me at glo(at)wild-mind.net and I'll help you get it sorted out.

Topic Closed

This topic has been closed to new replies.

About this Topic