WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Some Users See Home Page as 404 (10 posts)

  1. Daemus
    Member
    Posted 2 years ago #

    I am working on a site, using WordPress 3.2.1, the Suffusion theme, and a few popular plugins.

    When I see the site, all is well. When another user sees the site, the home page shows a 404 page. He can see any direct link page fine. His experience does not change if I set permalinks settings as default or use my custom ones.

    I have permalinks configured through the WordPress Permalink Settings. I have the home page set to a static page in the Reading section of the WordPress settings.

    I am at a loss for what is happening here. The user and I have the same version of FireFox for viewing. He confirmed that he isn't using any type of script/content blocker.

    The site is http://www.articleaggregate.com/

    Any help you can provide is appreciated. If you need more information, please let me know.

  2. Jonas Grumby
    Member
    Posted 2 years ago #

    What happens if you switch themes & deactivate all plugins? I see that there is no problem getting to your login & register pages. Are you able to log in?

  3. Daemus
    Member
    Posted 2 years ago #

    Thanks for taking a look Jonas.

    I am having absolutely no problem with the site. I can access everything fine.

    I can't seem to replicate the problem that the person I was having taking a look at it has. He gets a 404 error on the front page only, he can access everything else with absolutely no problem.

    He had looked at it before and did not have any problems, only this morning has this come up. I disabled the plugins I installed since he last looked at it and he still had the problems. I am at a complete loss as to why he gets a 404 on the front page (and front page only).

    Jonas, when you looked at it, did you encounter a 404 on the front page, or did it work fine for you?

  4. Jonas Grumby
    Member
    Posted 2 years ago #

    Yes I got a 404 as well. Is your wp-config (or something else) pointing to files on your hard drive? That would explain why only you can see it. Did you develop the site (and database) on your local computer and then upload it?

  5. govpatel
    Member
    Posted 2 years ago #

    I see that your article opens fine did you check Settings>>>General see what you using if you using static pages did you select the page as home page.
    Did you create a Home page as I do not see one in menu

  6. Daemus
    Member
    Posted 2 years ago #

    Jonas, thanks again for replying. I developed it completely on the web server it is currently on. All files are pointing to the web, nothing local.

    Govpatel, I think I get what you are saying, but I am not completely sure, so I will try to give a little info here. Under Settings >> General I have WordPress address (URL) and Site address (URL) both pointing to http://articleaggregate.com

    Under Settings >> Reading, Front page displays >> A static page >> Front Page selected as "Home Page". The actual page for Home Page has the Permalink set by default to the site url.

  7. Safirul Alredha
    Member
    Posted 2 years ago #

    Daemus, try logging out. Can you see the page now?

    What's the Status and Visibility for that page you set for static page?

  8. Daemus
    Member
    Posted 2 years ago #

    Thanks a ton Safirul.

    I spent hours combing through the backend, trying to figure out what plugin or setting was messing with it.

    I will probably spend the next few hours cursing at myself. At some point, I had put the page back into Draft status. I hit publish on it and now it displays fine.

    My apologies to everyone who took the time to help. I can't believe I was so stupid with this. Thanks to you all for your help.

  9. govpatel
    Member
    Posted 2 years ago #

    Your Homepage I can see now and is it a post page if so you need select 1st option in Settings>>>Readings

  10. Daemus
    Member
    Posted 2 years ago #

    Govpatel, thanks for looking at it again. It displays as I want it to now.

    Rather than using a post page, I am using a static page that is controlled by the Suffusion theme. The Suffusion theme has a built-in Magazine template that I am using to handle the static page.

    I set up the Magazine style template the way I wanted it and assigned the template to the static page that I set as the home page. As new posts are made on the blog, the Suffusion theme automatically updates the static page that I am using as my home page with the changes per the settings I chose for it.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.