WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Some posts are showing this message below: Sorry, the comment form is closed ? (14 posts)

  1. inderjeets
    Member
    Posted 3 years ago #

    I've enabled comments for my posts, but my some posts are showing this message below: Sorry, the comment form is closed at this time.

    Can someone tell me the solution ?

    Thanks and take care !

  2. elfin
    Moderator
    Posted 3 years ago #

    edit the post and enable comments... (in the Discussion box) ?

  3. inderjeets
    Member
    Posted 3 years ago #

    Thanks for the reply ! But, I've enabled that that's why some posts are showing comment box below, but some are not like this one: http://howto-tips.com/2011/01/24/how-to-break-into-your-car-easily-and-quickly/

  4. elfin
    Moderator
    Posted 3 years ago #

    enabling comments for posts doesn't change any individual settings you have per post - which is why I though of the above.

    Does changing that setting alter what is shown?

  5. Sayontan Sinha
    Member
    Posted 3 years ago #

    But, I've enabled that that's why some posts are showing comment box below

    Most beginners generally get confused between settings in 2 different places, or simply overlook the settings in one place.

    The first is under Settings → Discussion → Allow people to post comments on new articles. As it says, it only enables comments for new articles.

    What about articles that already exist with comments closed at the time of changing this setting? For that there is another setting in the individual Edit screen for the page/post. If you scroll down you will see a box for "Discussion", which has two lines:

    • Allow comments.
    • Allow trackbacks and pingbacks on this page.

    Set them as appropriate.

  6. inderjeets
    Member
    Posted 3 years ago #

    Thanks a lot Rich and dear Sayontan once again ! I've done according to your instructions. But, still some posts don't show up comments section, and say 'Comment Form is Closed'

  7. Jamal Mohamed
    Member
    Posted 3 years ago #

    There's another option in Settings → Discussion → Automatically close comments on articles older than [x] days. It closes posts automatically after defined number of days.

    So, make sure that checkbox is cleared, too.

  8. inderjeets
    Member
    Posted 3 years ago #

    I've also set that box for 1,000 days. Still, comment section is showing up closed for new articles dear Jamal.

  9. elfin
    Moderator
    Posted 3 years ago #

    Can you link to a page where comments are open?

  10. inderjeets
    Member
    Posted 3 years ago #

  11. elfin
    Moderator
    Posted 3 years ago #

    Ok temporarily change theme to twentyten, and deactivate all plugins - does that fix it?

  12. inderjeets
    Member
    Posted 3 years ago #

    Thanks once again buddy ! I've done that as well, but still the result is same. It's really getting messy.

  13. Sayontan Sinha
    Member
    Posted 3 years ago #

    If the result is the same then the problem is definitely in missing one of the instructions above (i.e. it has nothing to do with the themes you are using). You can start by posting links to screenshots of your entire Edit Page/Post screen for the posts.

  14. inderjeets
    Member
    Posted 3 years ago #

    Thanks Sayontan Sinha for ur reply ! I've solved my problem. I deactivated my all plugins once again, and found out the real culprit.

    Thanks a lot again for your reply !
    Take Care !

Topic Closed

This topic has been closed to new replies.

About this Topic