WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] some iframes don't in wordpress? (4 posts)

  1. Tim
    Member
    Posted 11 months ago #

    I have discovered something, much to my confusion and frustration.
    some iframes don't seem to like to work at all in wordpress.

    but some do.

    youtube/vimeo embeds work fine.

    most iframes seem to work fine, i've used them to embed entire pages from other sites like amazon.

    but when i try to embed banners or specific product widgets from amazon, they don't work at all. I get nothing but empty space.

    but when i put those same banners and widgets in a static html page for testing purposes, they work perfectly fine.

    anyone have an idea why they will not work in wordpress?

  2. Andrew
    Forum Moderator
    Posted 11 months ago #

    If they include JavaScript then they will probably break, can you link to a specific example of a broken iFrame & tell us the iFrame code you used?

  3. Tim
    Member
    Posted 11 months ago #

    i figured it out. idk why it never occurred to me.

    its a browser issue.
    for some reason the aforementioned iframes don't display in chrome (but only chrome for mac apparently).

    which is highly unfortunate as i am forced to work on a mac and much prefer to use chrome but a code monkey's gotta do what a code monkey's gotta do.

  4. Tim
    Member
    Posted 11 months ago #

    Apologies for wasting your time

Reply

You must log in to post.

About this Topic

Tags