WordPress.org

Ready to get started?Download WordPress

Forums

SOME HELP PLEASE (11 posts)

  1. angelo1
    Member
    Posted 5 years ago #

    MY PROBLEM IS THE FOLLOWING:

    I have a domain ( me.com )

    I added WP, but to access the blog is on a different file as follows

    me.com/blog

    how can i make the main domain to become my blog and when people come to my site they should be able to go to my store or post on the blog..

  2. MichaelH
    Member
    Posted 5 years ago #

    To make WordPress available at http://me.com just change in Settings->General, the Blog address (URL) to http://me.com and put this index.php file in your web-root folder (it is the same folder that contains the blog folder)

    <?php
    /* Short and sweet */
    define('WP_USE_THEMES', true);
    require('./blog/wp-blog-header.php');
    ?>

    Then update your permalinks in Settings->Permalinks.

  3. angelo1
    Member
    Posted 5 years ago #

    my dear friend thnak you just to re-cap/

    originally my domain is ex ( me.com ) a party store, and I wanted to add a blog so my hsoting gave me the way do it. I USED fantastico. so the installation when fine, but there is a option where they ask about the blog or root and I choose blog, now when you visit my store you can not see the blog because to access to the blog you need to add the word blog at the end of the domain. all I want to have all in one..

    here is my site... http://www.azecorp.com

    then add the word blog to visit the blog but people will not be able tofind out about the blog unless they type blog ...I hope that you understand my issue.. Thanks muchhh

  4. MichaelH
    Member
    Posted 5 years ago #

    To make WordPress available at http://www.azecorp.com just change in Settings->General, the Blog address (URL) to http://www.azecorp.com and put this index.php file in your web-root folder (it is the same folder that contains the blog folder)

    <?php
    /* Short and sweet */
    define('WP_USE_THEMES', true);
    require('./blog/wp-blog-header.php');
    ?>

    Then update your permalinks in Settings->Permalinks.

  5. You'll have to delete your index.html page for that to work, BTW.

  6. angelo1
    Member
    Posted 5 years ago #

    thank you you guys are the best

  7. angelo1
    Member
    Posted 5 years ago #

    guys i just made a mistake.
    HERE IS WHAT I DID:

    in setting I changed the Blog address (URL) to http://azecorp.com

    then i when to permalinks and I changed Common settings to custom Custom Structure : http://azecorp.com

    and I deleted the index.html form the root folder

    the last thing I did was to upload the index.php from the blog folder to the public_html folder but it does not work please check the site

    http://www.azecorp.com

    please reply and sorry for the inconvenience..

  8. MichaelH
    Member
    Posted 5 years ago #

    Use this for your index.php and use a correct editor!

    <?php
    /* Short and sweet */
    define('WP_USE_THEMES', true);
    require('./blog/wp-blog-header.php');
    ?>
  9. angelo1
    Member
    Posted 5 years ago #

    MichaelH,

    just followed your guide but it does not work please check my site and see that it does no work..

    yuyo

  10. MichaelH
    Member
    Posted 5 years ago #

    Assuming your WordPress files are in a folder called blog in your web-root folder then your WordPress Address should be http://azecorp.com/blog and your Blog Address should be http://azecorp.com (see Administration > Settings > General).

    If you can't get into your admin section, use phpMyAdmin to make sure your wp_options table has the correct values in siteurl and home.

    siteurl is your WordPress address (URL) and home is your Blog Address (URL).

    Also I see you have an error when browsing to http://azecorp.com/blog/ so you may need to reupload the index.php file there. That index.php would be the one in the wordpress folder in the download (see Download tab at top of this screen), not the index.php file in your web-root folder.

  11. angelo1
    Member
    Posted 5 years ago #

    Hello again, can someone please tell me if this is how my site should be configured on word press see below:

    WordPress address (URL) http://azecorp.com/blog

    Blog address (URL) http://azecorp.com
    Enter the address here if you want your blog homepage to be different from the directory you installed WordPress

    reply thanks

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.