WordPress.org

Ready to get started?Download WordPress

Forums

Some further details on the W3 minify failure (12 posts)

  1. eferm2
    Member
    Posted 2 years ago #

    This is mainly intended for the plugin's author, who has most certainly created the most useful WordPress plugin out there. Hopefully I can help making it work again.

    In short, minify doesn't work; regardless if I use auto or manual. With auto I get 'wrong param" for both CSS and JS when trying to download the files. Also, it doesn't support CDN (I use Cloudfront).

    With manual, there seems to be two problems:
    1. A minified CSS-file is produced to wp-content/w3tc/min/minify_5f67...css as well as files wp-content/w3tc/min/8a12d/default.include.css.id and wp-content/w3tc/min/8a12d/default.include.js.id. Both the default.include... files only contain a key/value pairs 'i:12...' and 'i:18...' respectively.
    2. No minified JS-file is produced at all.

    Regarding CDN, the minified CSS-file is correctly uploaded to Cloudfront. However, in the generate HTML, the following two CSS and JS URLs are given (on the CDN): wp-content/w3tc/min/8a12d/default.include.12...css.gzip and wp-content/w3tc/min/8a12d/default.include.18...js.gzip. Both don't exist, and if followed only return a "NoSuchKey The specified key does not exist" errors. The site is thus without CSS and JS.

    Further settings that I have seen mentioned: I have tried with both URL rewriting on and off; various minification algorithms; CDN on and off; and of course, minify auto and manual.

    So... No Javascript is generated and generated HTML point to URI for CSS and JS that don't exist -- either on my own server or on the CDN.

    I'm happy to provide further details if that helps.

  2. SlowClicksDotCom
    Member
    Posted 2 years ago #

    You should email him, really. Using the bug report button in the plugin's admin panel.

  3. eferm2
    Member
    Posted 2 years ago #

    True that. Might be interesting for more people to see though.

  4. DanMichel
    Member
    Posted 2 years ago #

    i turned everything off, but minify to debug, but it's totally not working

  5. jonhuther
    Member
    Posted 2 years ago #

    Is the issue minify or gzip?

    I gone through same things you mention above, but minify seems to be fine, it's when I turn on gzip and the .gzip extention is added that my css and js don't work.

    I have minify on now still, but I have to turn off gzip on css/js and html to have the css and js working on the site.

    Also using CloudFront.

  6. frg
    Member
    Posted 2 years ago #

    @jonhuther

    that´s a good point! in the end it IS GZIP what the error converges to.
    i can switch on minify for js and css => js and css broken follows

    but if i disable "Enable HTTP (gzip) compression"
    in W3TC/Browser Cache/Cascading Style Sheets & JavaScript my page is fine!

    no more "Bad file param format" when i try to read a css or js or just testfile.txt from the minify cache ..wp-content/w3tc/min/0fb4a/ in my case.

    so something with the .htaccess is fishy..

  7. jonhuther
    Member
    Posted 2 years ago #

    I always have the htaccess rewrite message at the top of the page too in the admin when gzip and minfy are on, so maybe it's a simple htacccess rewrite issue that isn't working so it doesn't know where files with .gzip as the extension are?

  8. josedavid
    Member
    Posted 2 years ago #

    I just disabled minify in W3 and used a seperate plugin called wp-minify. Cant see a problem with that yet.

  9. Leo Plaw
    Member
    Posted 2 years ago #

    I too have a similar problem. All external JavaScript and CSS files are not being minified and combined.

    I also see this message in the admin.

    Recently an error occurred while creating the CSS / JS minify cache: Some files were unavailable, please check your settings to ensure your site is working as intended.

    When I look at the console errors the browser reports, I see a 404 error for the missing combined files.

    default.include.2873786729.js Failed to load resource: the server responded with a status of 404 (Not Found)

    default.include.3658040327.cssFailed to load resource: the server responded with a status of 404 (Not Found)

    This of course slows down my page load time. The complete opposite of what the plugin is meant to do.

    I have also had recently the same problem that @jonhuther mentioned.

    I have also logged a bug report with the author.

  10. magaworks
    Member
    Posted 2 years ago #

    Is there no solution for this yet? The onlye solution I have right now is to disable Minify entirely so mt site works fine. :(

  11. frg
    Member
    Posted 2 years ago #

    @magaworks

    did you try to disable "Enable HTTP (gzip) compression" in W3TC/Browser Cache/Cascading Style Sheets & JavaScript?

    then you should have minify - but no gzip (which is not working correctly anyway).

    - then you should have the minimum loss of functionality..

  12. Frederick Townes
    Member
    Posted 2 years ago #

    Sorry for the trouble everyone. Hopefully the latest release of the plugin is better.

Topic Closed

This topic has been closed to new replies.

About this Topic