WordPress.org

Ready to get started?Download WordPress

Forums

Some feedback please on 2 blogs (5 posts)

  1. IvanTurbinca
    Member
    Posted 2 years ago #

    My first one is a personal blog: http://alexamarandei.ca

    And second one well I guess the name says a bit about it: http://routersecure.com

    I know it's a little bit strange but the domain was free so heh.

    I started using WP short of 2 weeks ago.

  2. Pothi
    Member
    Posted 2 years ago #

    Both look cool. I especially like the routersecure's theme and its implementation. I'm sure if you get content in it, it'd look even more cooler. You've made a great start in using WordPress.

  3. southcast
    Member
    Posted 2 years ago #

    In the second blog :
    1. Permalinks have not been set for blog post urls, dunno if that is done intentionally but people generally set their permalinks to be more seo friendly.
    2. The author thumbnail below the post is bleeding out of the div element.
    3. The first post is almost with no content, doesnot give much value to the visitors.
    P.S - Loved the theme. It is fast and classy.
    Cheers.

  4. IvanTurbinca
    Member
    Posted 2 years ago #

    Check it now and post back some more feedback. Thank you. It's helping me a lot.

    LE: I have some strange problem though, nothing major just annoying. For example my last phrase on the test post ended with a "." but it's not showing on the front page, but if you click on the post it shows.

  5. IvanTurbinca
    Member
    Posted 2 years ago #

    Fixed some bugs, optimized for SEO, added more content.

Topic Closed

This topic has been closed to new replies.

About this Topic