WordPress.org

Ready to get started?Download WordPress

Forums

PHP Browser Detection
[resolved] Some errors in description (2 posts)

  1. BramVanroy
    Member
    Posted 11 months ago #

    Hello

    Great plugin! I always used jQuery for browser sniffing, but this is even better!

    A small piece of advice though, please update the description of this plugin. Also, there are some errors there, such as:

    Check for greater than / less then a specific version...

    Check for greater than / less than a specific version.

    Less than or equal to Firefox 19:
    <?php if(is_firefox() && get_browser_version() >= 19) { /* do stuff */ }; ?>

    Has to be:
    <?php if(is_firefox() && get_browser_version() <= 19) { /* do stuff */ }; ?>

    Less than or equal to IE 10:
    <?php if(is_ie() && get_browser_version() < 10) { /* do stuff */ }; ?>

    Has to be:
    <?php if(is_ie() && get_browser_version() <= 10) { /* do stuff */ }; ?>

    Greater than or equal to Safari 4:
    <?php if(is_safari() && get_browser_version() > 4) { /* do stuff */ }; ?>

    Greater than or equal to Safari 4:
    <?php if(is_safari() && get_browser_version() > 4) { /* do stuff */ }; ?>

    Has to be:
    <?php if(is_safari() && get_browser_version() >= 4) { /* do stuff */ }; ?>

    And so on.

    http://wordpress.org/extend/plugins/php-browser-detection/

  2. Mindshare Studios, Inc.
    Member
    Plugin Author

    Posted 6 months ago #

    Thanks these will be fixed in the next update!

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.