WordPress.org

Ready to get started?Download WordPress

Forums

Contact Form 7
Some emails from Contact Form 7 marked as spam by gmail (3 posts)

  1. StinaQ
    Member
    Posted 1 year ago #

    Hi!
    I know this question has been asked a lot, but I can't find a clear answer.

    We've been using contact form for quite a while on our site torns.org and it's been working fine up until recently. Suddenly a large number of sent forms ended up i gmails spam filter and it wasn't discovered until too late, which resulted in sad kids who wasn't registered for their riding lesson!

    But to the point: I know this isn't exactly contact form 7 "fault", but I want answers on how to get around it! From what I've read you can change the "from"-address to your own, but must you then mark that specific address as a safe sender? Our problem is that the recipients (the ones that the forms are sent to) of the forms are not super computer friendly all the time and they are also very many, so ideal would be that they didn't have to do anything.

    And does it work, setting another address in the from-field? Or is there another way?

    TL;DR How do I stop gmail from sending emails sent via contact form to spam?

    Really grateful for help!

    http://wordpress.org/extend/plugins/contact-form-7/

  2. davidacardona
    Member
    Posted 1 year ago #

    Hi, I partially solved this in a very funny way. I opened the message that was sent to spam with the option "show original" that is in the right upper corner of the specific message.

    There, between those incomprenhensible letters i found the address that my dreamhost server was using to send the messages. it wass something like "myhostuser@myhostingdomain.com", after i went back to gmail and created a filter with that address "myhostuser@myhostingdomain.com" and marked it ask "never send to spam".

    It already solve it, but to do it nicer, i went back to Contact Form 7 and edited my "From" form field with the address "Web form" <myhostuser@myhostingdomain.com>

    and now i'm receiving all site mail in the inbox with a nice add that it should be on spam

  3. contacternst
    Member
    Posted 1 year ago #

    Nice job David, that's the same thing I did! I wrote a more in-depth blog post about how to do this complete with an example :)
    http://www.directvermont.com/contact-form-7-dreamhost-how-to-fix/

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags