WordPress.org

Ready to get started?Download WordPress

Forums

Woocommerce CSV importer
[resolved] Some bugs (7 posts)

  1. fransberns
    Member
    Posted 1 year ago #

    Hello
    Great plugin, but I think that version 0.7.0 it has some bugs:

    1.- The script ignore the first line of import.csv
    Instead of:
    92 $row = 0;
    ... should be:
    92 $row = 1;

    2.- Instead of:
    185 if (isset($data[12]) && $data[11] )

    ... should be:
    185 if (isset($data[11]) && $data[11] )

    3.- Instead of:
    180 //set the height

    ... should be:
    180 //set the width

    4.- Line 131 is unnecessary:
    131 $row ++;

    http://wordpress.org/extend/plugins/woocommerce-csvimport/

  2. allaerd
    Member
    Plugin Author

    Posted 1 year ago #

    hello fransberns,

    Thanks for the info. Fixed them in 0.7.1

    except the row thing. in line 99 i check this: if ($row <> 0 ) $csvcontent[] = $line;.

    Version 1.0 will be out soon. And will be rebuild from scratch.

  3. kyagi
    Member
    Posted 1 year ago #

    Hi Allaerd, on 0.7.1 the problem of time out error 500 persist also with "experimental background settings"...

  4. allaerd
    Member
    Plugin Author

    Posted 1 year ago #

    Hi there,

    The time out error is because you probably are trying to import a large amount of rows. You can change your apache settings to have a higher timeout or split the csv file into smaller chunks

  5. kyagi
    Member
    Posted 1 year ago #

    Hi Allaerd,
    I sent you an email with a csv sample of only 15 products.. in normal mode work well but if i increase product i get time out error, in "experimental background settings" only first row it's imported.. it's very strange..

    Thanks for support

  6. allaerd
    Member
    Plugin Author

    Posted 1 year ago #

    Hi there,

    I tried your csv with no problems at all. I think you really should check your server

  7. kyagi
    Member
    Posted 1 year ago #

    Thanks Allaerd,
    I sent an email to my hosting provider to find a solution..
    For now in .htaccess file on wordpress root I've inserted this code to expand time out:

    php_value max_execution_time 600

    Thanks for support and for your fantasti plugin..
    to be perfect in future version add the possibility to update only stock, price and insert attribute for manufacturer.

    Regards

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.