WordPress.org

Ready to get started?Download WordPress

Forums

Solved My "Insert Image into Post" Blank Popup Problem - Sharing (17 posts)

  1. TeddyBare
    Member
    Posted 6 years ago #

    I hope this is the right place to share this.

    I have 3 WordPress driven sites that I have upgraded to WordPress 2.5 this week, and I had the same problem that others had, that when I clicked the insert into post button on the media manager, the popup window went white, and stayed there and nothing else happened.

    Having tried all the solutions, and having found it worked now and again seemingly randomly, tonight I discovered a scenario I could reproduce and a fix.

    Typically I have Firefox open on my main website, and then I open one of the other sites in another tab. When the site I am editing is on the second tab (haven't tested further than that) "Insert Image into Post" produces a white popup screen, if I close the first tab I can then insert images perfectly.

    Why this would solve it, I don't know, and this may just be a quirk of my system, but I wanted to share in case its not just me!

  2. rikez
    Member
    Posted 6 years ago #

    Yups... i have the same problem.
    dont know why? but maybe next time there's an update to fix this bug. Hope.

  3. rikez
    Member
    Posted 6 years ago #

    the same problem also when i try to insert a link into my post.

  4. Asukavalentine
    Member
    Posted 6 years ago #

    Same problem here when I try to insert images. I don't like this new flash gallery at all...

  5. reviewabc
    Member
    Posted 6 years ago #

    I just find the solutions for this bugs. It takes 4 hours for me to search in google. But worthed. Finally i found it.
    You guys can give it a try. I post the solution in my blog : http://reviewabc.com

  6. bazil749
    Member
    Posted 6 years ago #

    @reviewabc: I'm not sure what your motives are, but there are a few things wrong with them. 1. You don't simply list the solution here which makes me think you're just looking for some traffic (which you got).

    2. You didn't link to any post, just the main blog. So now I have to search through all your posts looking for the solution. This further makes me think you're only looking for traffic.

    3. The attached file can't be downloaded.

    So with all this being said.

    Could someone please help me. I have three blogs, all upgraded at the same time. 2 don't work, one does. I've even hit the deactivate all plugins button.

    WP 2.5 is really turning out to be a pain in the butt.

  7. murk
    Member
    Posted 6 years ago #

    Thanks TeddyBare!
    I was experiencing exactely the same problem and your 'solution' works perfectly.
    Cheers!

  8. kristanlh
    Member
    Posted 6 years ago #

    Oh man, this is great! It IS because of the tabs. For me, WordPress had to be the ONLY tab.

    Now we have a temp "fix." (THANK YOU THANK YOU THANK YOU!)

    But I hope someone will come up with a way to let us upload images while we have other tabs open...

  9. croxie
    Member
    Posted 6 years ago #

    Thank you, TeddyBare :D
    That really works.

  10. mhennie
    Member
    Posted 6 years ago #

    Having problems uploading images; problem started on Monday. Using WP 2.3.3 as my hosting network hasn't yet made WP 2.5 available. Can't upload images and I've tried several suggestions including turning off plug ins, clearing cache in Safari (running iMac, 10.5.2), installing latest Flash player and downloading Firefox and trying that. None of it works. What gives? Blog's at a standstill because I can't upload photos to the posts. Help!?

  11. clevermonkey
    Member
    Posted 6 years ago #

    Ha! Life is good again. Thanks for the fix, works for me!

  12. the-me
    Member
    Posted 6 years ago #

    I have somewhat different experiences on that.

    On my site the problem occurs also with the "add link" button (or shift-alt-a on the mac). The window is blank, although I can close it. I also had this behavior with WP 2.4.

    The solution I ran over was: In the blog settings I had http://mysite.tld instead of http://WWW.mysite.tld. Since I changed that, all is sugar.

    BUT NOT QUITE - I was just lucky :-) . I usually edit my wp-admin stuff with https. With HTTPS the window is still blank, with HTTP it works fine.

    Can anyone confirm this, maybe?

  13. n8uri
    Member
    Posted 6 years ago #

    Everyone: I've got the fix:

    Check your browser's address bar at the top (where your http://blahblah.com address is)

    If you're coming from any site that uses a masked forwarded domain, it won't work. When you insert media into post while your browser's address bar has the same domain name in it as the one listed in your blog's settings > General - WordPress Address URL, it will work just fine.

    I tried it with other tabs open, Firefox and Safari. I don't think it's browser dependent. The reason for inconsistency is probably from visiting forwarded masked domain sites, coming from frames, and all other sorts of ways in which your address bar will say something besides what it should.

    Hope this finally puts this huge issue to rest!

  14. jjtiziou
    Member
    Posted 6 years ago #

    Hi there everyone,

    I'm encountering this same problem in a new upgrade to 2.6.1, and the suggestions with tabs aren't working for me... any suggestions on anything else to try?

    When I click "insert into post", the inner window switches to my site's 404 not found page... What am I missing?

    Many thanks in advance,
    -jj

  15. jjtiziou
    Member
    Posted 6 years ago #

    Ok, so paying attention to this support thread:

    http://wordpress.org/support/topic/164999?replies=1

    solution #6, with mod_security ended up solving the problem...

    here's the answer:

    mod_security might be causing problems. Disable it to see if that is the problem. To do this, make an .htaccess file in your wp-admin directory. Add this to it:
    <IfModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </IfModule>
    That will disable mod_security for the upload file receiving code in the wp-admin directory.

  16. gyuri
    Member
    Posted 5 years ago #

    This fixed the problem of the TinyMCE popups not showing for me (found it after some more googling):
    http://mu.wordpress.org/forums/topic.php?id=3481

    It comes down to:
    Editing the function _print_scripts in wp-includes/script-loader.php

    function _print_scripts( $handles ) {
      global $wp_db_version;
      if ($_SERVER['HTTPS'] == 'on') $https=True; // added line
      ...
      if ($https) $src = str_replace('http://','https://',$src); // added line
      echo "<script type='text/javascript' src='$src'></script>\n";
      ...
  17. edgarsso
    Member
    Posted 5 years ago #

    Hello Guys! Happy to have another solution!
    I tried everything that was specified above and nothing worked... however, while reading one of the the links referred above it clicked! Right before I start having this type of problems I was messing with the Permalinks... I went back and removed any customization I made and voila! Problem solved!

    I hope it helps you guys!

Topic Closed

This topic has been closed to new replies.

About this Topic