WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Solution: Unable to Create Upload Directory (16 posts)

  1. Forrest_Snyder
    Member
    Posted 5 years ago #

    Some hosting providers have problems with the default WordPress directory structure.

    Problem:

    WordPress Error: Unable to create directory /wp-content/uploads/2009/mydir/summer/ Is its parent directory writable by the server?

    Solution:

    In order to fix this error please login to the wordpress dashboard ( http://www.domainname.com/wp-admin ) and access the Miscellaneous settings. Find the uploads path specified, it will most likely be specified as:

    "/wp-content/uploads/

    Change it to read

    "wp-content/uploads/

    After the first " / " is deleted, save settings, and that will fix this error.

  2. izulien
    Member
    Posted 5 years ago #

    Forrest_Snyder, I think I love you! I tried trillions of other things and it didn't work at all. This worked right away!

  3. James_Harris
    Member
    Posted 4 years ago #

    This is one of the best kept secrets of wordpress. I tried a ton of things with no luck. This solved my problem.

  4. dublinedanto
    Member
    Posted 4 years ago #

    Thanks for the tip.

    In my case - it didn't work. I am still getting the error with my new install and can't upload images in posts (my workaround is to use FTP)

    I'm an amateur when it comes to this, but it is clear that I shouldn't set permissions to 777. I tried setting them to 766, and I still get that error.

    Is there something else that I could adjust to get rid of this error?

    thanks

  5. smilesfromsusan
    Member
    Posted 4 years ago #

    This solved my problem too. I also had tried a zillion other things first.

    Whew!

  6. Plastik7
    Member
    Posted 4 years ago #

    solved my problem too!
    thanks a lot!

  7. adreson
    Member
    Posted 4 years ago #

    delete " / " didnt work.

    I asked to my host solve this problem.

  8. ammarali0300
    Member
    Posted 4 years ago #

    Hello
    I am using WordPress 2.8.6.
    In Miscellaneous Settings I set the path to wp-content/uploads/
    and check the checkboxes
    -"Organize my uploads into month- and year-based folders" and
    -"Track Links’ Update Times"
    But i got still the same error which is
    " Unable to Create Upload Directory"
    so please help.

  9. paulcj2
    Member
    Posted 4 years ago #

    I have tried all these things, too. Am still having the same problem.

  10. Mark / t31os
    Moderator
    Posted 4 years ago #

    See if anything in the sticky helps.
    http://wordpress.org/support/topic/164999?replies=1

    NOTE: The above is incorrect to, the upload path should be(as per default) ..

    wp-content/uploads

    not..
    /wp-content/uploads/ or /wp-content/uploads

    The path isn't necessarily the cause of the "Unable to create directory" type errors anyway, though it may be true for "some" users.

  11. Theof
    Member
    Posted 4 years ago #

    Here is the message that I was getting...

    Unable to create directory /mnt/local/home/theof/lacanadapreschool.com/wp-content/uploads. Is its parent directory writable by the server?

    What I realized is that my permissions were correct but somehow this site got switched to a "local" setting. To be honest I've taught myself everything I know about WP and I still don't know much. However I know I've never set the site to a "local" mode.

    I run another site with the same theme, same server and everything works. So what I did was under the Misc settings the path I looked at two sites that use the same theme, the same server etc. What I realized was that the site that did not work properly had the /mnt/local in the path and the one that works did not. So I deleted the extra text and success!

    Again, I don't know how this happened but maybe this can help someone else!

    Good:
    /home/theof/sherylobryan.com/wp-content/uploads

    Bad:
    /mnt/local/home/theof/lacanadapreschool.com/wp-content/uploads

  12. mStarDesigner
    Member
    Posted 4 years ago #

    Please help! I'm unable to upload images. Here's the error:

    Upload error: The userphoto upload content directory does not exist and could not be created. Please ensure that you have write permissions for the '/userphoto' directory. Did you put slash at the beginning of the upload path in Misc. settings? It should be a path relative to the WordPress root directory. wp_upload_dir() returned:
    <code style='white-space:pre'>Array ( [error] => Unable to create directory /var/www/vhosts/newmoonski.com/httpdocs/wordpress/wp-content/uploads/2010/06. Is its parent directory writable by the server? )

    I've tried changing the misc. upload path to wp-content/uploads but no luck.

    PLEASE help!
    Thank you!

  13. esmi
    Forum Moderator
    Posted 4 years ago #

    Change the permissions on the wp-content directory to 766. If you still have problems, try 767 or 777. Once your uploads are working, change the permissions on wp-content back to 755 again and check that everything still works OK.
    http://codex.wordpress.org/Changing_File_Permissions

  14. mStarDesigner
    Member
    Posted 4 years ago #

    I'm completely confused. I'm using FTP permissions, turning the permissions on an off. When I make the wp-content 766, my blog vanishes into thin air - a completely white page.

    When I try 755, the blog is back, however I still cannot upload an image. Same error:

    Upload error: The userphoto upload content directory does not exist and could not be created. Please ensure that you have write permissions for the '/userphoto' directory. Did you put slash at the beginning of the upload path in Misc. settings? It should be a path relative to the WordPress root directory. wp_upload_dir() returned:
    <code style='white-space:pre'>Array ( [error] => Unable to create directory /var/www/vhosts/newmoonski.com/httpdocs/wordpress/wp-content/uploads/2010/06. Is its parent directory writable by the server? )

    Would I need to change permissions on the uploads folder? And/or the userphoto folder?

  15. mStarDesigner
    Member
    Posted 4 years ago #

    Also, I get an error when trying to add an image to a blog entry (as the admin of the blog):

    Unable to create directory /var/www/vhosts/newmoonski.com/httpdocs/wordpress/wp-content/uploads/2010/06. Is its parent directory writable by the server?

    I'm certain this is related… if the permissions can be enabled, will it allow me to add images to my entries as well as the userphoto?

  16. esmi
    Forum Moderator
    Posted 4 years ago #

    Try 767 or 777.

Topic Closed

This topic has been closed to new replies.

About this Topic