WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Solution for writing files problem in Google (XML) Sitemaps Generator (1 post)

  1. akulavolk
    Member
    Posted 6 years ago #

    I figured out a user-error problem on my part that some Google (XML) Sitemaps Generator for WordPress users may be experiencing. A number of people in the forums seem to have the same problem as me, so I thought it might be worth posting how I got this to work.

    I was repeatedly getting "There was a problem writing your sitemap file. Make sure the file exists and is writable." errors when trying to publish my XML Sitemap. I followed the instructions perfectly for pre-populating my server with blank sitemap.xml and sitemap.xml.gz files, and then assigning 666 or 777 permissions to the files. I still had the problem. I also tried the recommendations found here and in the README for upping memory and time. Still didn't help.

    Here's what I was doing wrong:

    In Custom Location option, there are two fields. I incorrectly assumed these were choices, so I filled in only the complete URL and not the Absolute or "relative path" option. I'm used to using EITHER a relative path, OR a full URL, not both at the same time, which may be what tripped me up. Once I used both a relative path and a complete URL, it worked flawlessly.

    Long story short, if you're having write file problems when creating your XML files, and you're using a "Custom" location (such as website root instead of /blog/), make sure you populate BOTH paths in the Custom field.

    Hope this helps...

Topic Closed

This topic has been closed to new replies.

About this Topic