WordPress.org

Ready to get started?Download WordPress

Forums

Author Spotlight (Widget)
[resolved] Social Networking clash (4 posts)

  1. radien
    Member
    Posted 1 year ago #

    I have two plugins that add Twitter to user's profile so I changed yours to wp_twitter in the functions.php as well as in author-profile.php, but somewhere along the line, the icon for twitter isn't showing up in the widget is, there something else I can do to fix it? your plugin requires the whole url, while the other only requires @somename

    http://wordpress.org/plugins/author-profile/

  2. Debashish
    Member
    Plugin Author

    Posted 1 year ago #

    Can you post the exact code snippets that you changed in the theme functions and the plugin? I cannot help much without looking at the code changes made.

    Also, did you enable the Twitter profile from widget admin screen (checked the checkbox)?

  3. radien
    Member
    Posted 1 year ago #

    I Forgot to re-enable it in the admin widget section, after i changed the array. but here's the code changes anyway.

    author-profile.php
    'wp_twitter' => array(
    'img_src' => $this->icon_image_url . 'twitter.png',
    'img_title' => 'Twitter',
    'img_seperator' => ' '
    ),

    functions.php
    if ( !isset( $contactmethods['wp_twitter'] ) )
    $contactmethods['wp_twitter'] = 'Twitter';

  4. Debashish
    Member
    Plugin Author

    Posted 1 year ago #

    Ok the code the changes should work and I hope after re-enabling the profile it worked for you.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.