WordPress.org

Ready to get started?Download WordPress

Forums

Sampression Lite
[resolved] Social media links on top right (4 posts)

  1. tadpaul353
    Member
    Posted 1 year ago #

    I've just noticed that my buttons to twitter and facebook are pointing to incorrect URLs...

    They seem to be picking up the url of the current page and appending my usernames, instead of appending my username to the twitter or facebook url.

    e.g. the twitter button points to http://www.fromadaddy.com/fromadaddy

    instead of http://twitter.com/FromaDaddy

    If I'm on a different page on my site, the twitter button will point to that url, e.g.

    http://www.fromadaddy.com/8-things-dads-should-do/Fromadaddy

    same sort of thing with facebook. (except paul.wandason instead of fromadaddy)

    I've entered under Theme Options - social media just "Fromadaddy" or "paul.wandason", i.e. no url information.

    I've completely reinstalled the theme (version 1.4) but the problem still exists.

    Does anyone have any pointers?

  2. noahjonah
    Member
    Posted 1 year ago #

    If the buttons work on some pages.....
    Try,

    1. Open the "page-template.php" that the buttons are working on.
    2. Cross check the code with the page that is not working.. maybe there is a small difference between the two pieces of code ( seems unlikely, but maybe something was messed up during editing )... but maybe....

  3. dharmapoudel
    Member
    Posted 1 year ago #

    Hey tadpaul353,

    They have changed that url for social media to make it more general.
    Previously you need to only insert your username but now you need to insert the full url as
    http://twitter.com/FromaDaddy
    not just FromaDaddy.

    This has a better side that you can insert link for social media other than facebook, twitter, youtube and google plus and just change the icon.

    Pleas let me know if this helps.

  4. tadpaul353
    Member
    Posted 1 year ago #

    Hi noahjonah and dharmapoudel,

    The links didn't work on any page, but I found a workaround by editing the header.php file in a child theme so that the call to twitter etc. was similar to the previous version of Sampression Lite (1.3.2.)

    i.e. from

    '<li class="sm-top-tw">" target="_blank">Twitter'

    to

    '<li class="sm-top-tw">" target="_blank">Twitter'

    Anyway...I've just deleted that child theme and entered the full url path in the options as you suggested, and it works!!! (a much better and simpler solution!)

    Strange that the theme says to enter only the username, but that's a minor detail I suppose!

    Many thanks! :)

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic