WordPress.org

Ready to get started?Download WordPress

Forums

Mantra
Social icons always activated (7 posts)

  1. UprisingSilver
    Member
    Posted 5 months ago #

    Similarly to faina09 I too have some problems with social icons.
    Since the update the social icons in the Top right and in the footer are always activated.
    The only way to make them disappear is to delete their links (but then they disappear altogether from the whole site - not exactly a solution...)
    Before, I had my socials activated only in the top right and everything was perfectly fine. Any suggestion? Thanks.

  2. BanditArtDesign
    Member
    Posted 5 months ago #

    I've got the same issue, earlier I had social links only in the footer now they appear on the header too.. Why?

  3. devon
    Member
    Posted 5 months ago #

    I've got the same problem after updating from 2.3.2 to 2.3.3.

  4. Forest Skills
    Member
    Posted 5 months ago #

    Ditto. It seems that Mantra has stopped making any savings that I make to its settings. Also html code in a widget (ie click here to subscribe to our newsletter) just doesn't work anymore - nothing has changed, it's just stopped working.

  5. Forest Skills
    Member
    Posted 5 months ago #

    Oh...

    http://www.cryoutcreations.eu/wordpress-themes/mantra/mantra-2-3-3-stays-in-line

    Seems the version of 2.3.3 on the WP servers is corrupted.

  6. davidpetersonharvey
    Member
    Posted 5 months ago #

    I found a workaround that seems to be working for the social icons reverting to the defaults. I hope this is useful for someone. I can't do the theme reinstall right now, so this took care of the main problem for me until I can get to it.

    I went to the admin directory of my theme /wordpress/wp-content/themes/admin and opened defaults.php in an editor.

    I found these items.

    "mantra_socialsdisplay0" => "1",
    "mantra_socialsdisplay1" => "",
    "mantra_socialsdisplay2" => "",
    "mantra_socialsdisplay3" => "1",

    (The lines above it are the default settings for each social title and link.)

    I didn't want the one on the top right of the screen, just bottom right and footer icons, so I edited as follows.

    "mantra_socialsdisplay0" => "",
    "mantra_socialsdisplay1" => "",
    "mantra_socialsdisplay2" => "1",
    "mantra_socialsdisplay3" => "1",

    This seemed to take care of the problem. I can edit the links and their titles in the theme no problem. It's just these lines that are the problem, because the theme keeps reverting to at least some of these from this file.

    So, what you're doing is hard coding changes into the theme defaults, which may disappear when you update the theme again. However, it will hopefully be fixed by that time.

  7. david
    Member
    Posted 4 months ago #

    Thank you. I just installed Mantra and your tip was priceless. I also noticed that if you set all four to null, i.e., "", that the menu options then work, letting you set and reset where the social icons appear from within Mantra.

Reply

You must log in to post.

About this Theme

About this Topic