WordPress.org

Ready to get started?Download WordPress

Forums

Social Connect
social-connect - Windows Live (16 posts)

  1. fezacakir
    Member
    Posted 3 years ago #

    Windows Live don't work

  2. jimaek
    Member
    Posted 3 years ago #

    Yeah, the button doesnt show up at all.

  3. jimaek
    Member
    Posted 3 years ago #

    Btw, i changed the code to show the button anyway but now i get this
    "Social Connect plugin has not been configured for this provider"

    I have successfully published the app and installed the php modules. No errors in Diagnostics

  4. sbweitzman
    Member
    Posted 3 years ago #

    How did you get the button to show up?

    I have the PHP sample working from Messenger connect... I wonder if the callback.php file will work if I submit back to that...

    Stu

  5. sbweitzman
    Member
    Posted 3 years ago #

    BTW, I love it when a plugin has thousands of downloads, but the author doesn't respond to any of the posts.

  6. jimaek
    Member
    Posted 3 years ago #

    @sbweitzman

    file ui.php

    change line 26 to:
    <?php if(1) { ?>

    But there is no point in doing this, because the button is not working anyway

  7. thenbrent
    Member
    Plugin Author

    Posted 3 years ago #

    @jimaek do you have all fields correctly setup for liveid? Including a valid policy URL? If so, can you check your php error log and let me know any errors it includes relating ot the problem.

    @sbweitzman have you tried turning it off and on again?

  8. jimaek
    Member
    Posted 3 years ago #

    @thenbrent I dont have php errors. My policy URL is http://www.domain.com/terms-of-service. Also the client id and secret key are copy paste from my application, i checked them like 15 times and everything is correct.

  9. thenbrent
    Member
    Plugin Author

    Posted 3 years ago #

    Hrm that's a pain, without any hint at the cause of the problem, I can't figure it out.

    At this stage I think I'll remove Windows Live support all together as other providers (Google/Yahoo) are working fine while Live just causes complaints.

  10. jimaek
    Member
    Posted 3 years ago #

    I found the problem, the following check fails

    ui.php
    $liveid_enabled = get_option('social_connect_liveid_enabled', 1) && get_option('social_connect_liveid_appid_key') && get_option('social_connect_liveid_secret_key') && get_option('social_connect_liveid_security_algorithm') && get_option('social_connect_liveid_return_url') && get_option('social_connect_liveid_policy_url');

    The options "social_connect_liveid_return_url" and "social_connect_liveid_security_algorithm" dont exists. I created them and the button appeared
    social_connect_liveid_security_algorithm = wsignin1.0
    social_connect_liveid_return_url = http://www.domain.com/wp-content/plugins/social-connect/liveid/callback.php

    Now the popup window apears and asks me to login, but after the login it just redirects me to my website's homepage.

  11. thenbrent
    Member
    Plugin Author

    Posted 3 years ago #

    Can you download this version and let me know if it's working: https://github.com/thenbrent/social-connect/zipball/master

    Also, when you're redirected to your website's homepage, are you logged in?

  12. jimaek
    Member
    Posted 3 years ago #

    If i am not logged-in in hotmail the popup window asks me my credentials, if i am logged-in in hotmail then i just get redirected to my homepage (in the popup window).

    Also now the popup window on the comments is opening twice (with all providers).

  13. sbweitzman
    Member
    Posted 3 years ago #

    @thenbrent - We're trying the same thing at this point, and getting the same result.

    After doing some pretty extensive research on this situation, the question has to be asked... How are you connecting a LiveID with the back-end WordPress system?

    We noticed that using a Yahoo ID and Google, a user is created, but not LiveID. How is the password set, if at all?

    I'm assuming that, after the token exchange, you're attempting to store the LiveID in the WP DB somehow...

    Apologies for the snarky comment... I was getting a bit punchy with this whole LiveID maneuver.

    Stu

  14. thenbrent
    Member
    Plugin Author

    Posted 3 years ago #

    Unless you guys have any compelling need to offer Windows Live, I'm going to remove it in the next release. I didn't write it and the person that did clearly hasn't tested properly.

  15. sbweitzman
    Member
    Posted 3 years ago #

    Actually, I DO have a compelling need... I'm doing some work for a client.

    I get your frustration though...

    Stu

  16. markusdrake
    Member
    Posted 3 years ago #

    Jimaek - did you ever figure things out? If you did... could you provide some working code for the Windows Live connection to solve this problem for other people?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic