WordPress.org

Ready to get started?Download WordPress

Forums

social connect plugin dont work with wp3.0.4 (7 posts)

  1. vorajinesh@gmail.com
    Member
    Posted 3 years ago #

    Hello All,

    We are in search of having openID integrated with WP 3.0.4 for achieving that we tried Janrain Engage ..but doesnt work on all network sites even if we do network activate ...

    later we came across social connect...we installed it we could not see any of the icons of the OpenID provider (we could see that the icons were missing)

    we had to edit its ui.php to get the icons in place and it was then visible on all network sites but on clicking icon nothing happens.

    Please anyone can help us or guide us to integrate OpenID on WP 3.0.4

    Waiting for reply.

    Regards,
    Jinesh

  2. davidryal
    Member
    Posted 3 years ago #

    See other thread about installing Social Connect in a different directory -- fixes the icon problem.

  3. thenbrent
    Member
    Posted 3 years ago #

    For others facing this problem, please change the /social-connect/ directory name to be /wp_social_connect/.

    This bug will be fixed in the first stable release.

  4. vorajinesh@gmail.com
    Member
    Posted 3 years ago #

    Hello thenbrent,

    on the other thread i got guidance from Ashwin regarding renaming the folder and now i m able to get login form of Google and yahoo and all ...but when i enter the credntial ans try to login i get following error

    This is probably not the site you are looking for!
    You attempted to reach centerstest.dadabhagwan.org.cactus.arvixe.com, but instead you actually reached a server identifying itself as *.arvixe.com. This may be caused by a misconfiguration on the server or by something more serious. An attacker on your network could be trying to get you to visit a fake (and potentially harmful) version of centerstest.dadabhagwan.org.cactus.arvixe.com. You should not proceed.

    and it gives me option to proceed anyway ..and if i do so then i get 404 page not found error on the following url ....

    https://centerstest.dadabhagwan.org.cactus.arvixe.com/wp-content/plugins/wp_social_connect/yahoo/connect.php?openid.ns=http://specs.openid.net/auth/2.0&openid.mode=id_res&openid.return_to=https://centerstest.dadabhagwan.org.cactus.arvixe.com/mumbai/wp-content/plugins/wp_social_connect/yahoo/connect.php&openid.claimed_id=https://me.yahoo.com/a/Uosl7OdivpUG0mFZHnHakJP9dpHI.f8-%233a5bb&openid.identity=https://me.yahoo.com/a/Uosl7OdivpUG0mFZHnHakJP9dpHI.f8-&openid.realm=https://centerstest.dadabhagwan.org.cactus.arvixe.com&openid.ns.ax=http://openid.net/srv/ax/1.0&openid.ax.mode=fetch_response&openid.ax.value.fullname=jinesh%20vora&openid.ax.value.nickname=jinesh&openid.ax.value.email=vorajinesh%40yahoo.co.in&openid.assoc_handle=AHtvlm70LvrWPvkWPsq_HMm6JiMxIVDMDcnHOvk9fo.HApN9Ln.BIOp5pVPNI4wW_ArO7jdiA9I_cSXNu6estYJsy53DG7j88xNbhzy7v56FoBJXXh4L8k5LMgsploDgUDk-&openid.response_nonce=2011-02-09T05:52:48ZvQXjS0Zvj4lIbD5G92XtFruxNz7_vKQPxw--&openid.signed=assoc_handle,claimed_id,identity,mode,ns,op_endpoint,response_nonce,return_to,signed,ax.value.fullname,ax.type.fullname,ax.value.nickname,ax.type.nickname,ax.value.email,ax.type.email,ns.ax,ax.mode,pape.auth_level.nist&openid.op_endpoint=https://open.login.yahooapis.com/openid/op/auth&openid.ax.type.fullname=http://axschema.org/namePerson&openid.ax.type.nickname=http://axschema.org/namePerson/friendly&openid.ax.type.email=http://axschema.org/contact/email&openid.pape.auth_level.nist=0&openid.sig=VoVmO/2QctceJ7fpcyS%2BVd6rGT0%3D

    Please guide me where i m going wrong ..waiting for reply.

    Regards,
    Jinesh

  5. thenbrent
    Member
    Posted 3 years ago #

    It's an SSL server configuration error. Your SSL certificate is a wildcard subdomain certificate, which is why it's throwing the error. You'll need to either get an SSL cert for centerstest.dadabhagwan.org.cactus.arvixe.com or fix your server config.

  6. vorajinesh@gmail.com
    Member
    Posted 3 years ago #

    Hello thenbrent,

    We have deployed whole new wordpress 3.1 with social connect 0.2 (centers.dadabhagwan.org)...and now we also have SSL in place so i m not getting any error but now after i try login in using gmail or yahoo i just get blank page after it gets authenticated ..following is the URL of that blank page.

    https://centers.dadabhagwan.org/wp-content/plugins/social-connect/google/connect.php?openid.ns=http%3A%2F%2Fspecs.openid.net%2Fauth%2F2.0&openid.mode=id_res&openid.op_endpoint=https%3A%2F%2Fwww.google.com%2Faccounts%2Fo8%2Fud&openid.response_nonce=2011-03-07T09%3A51%3A22ZXy57KcrSBIsuhA&openid.return_to=https%3A%2F%2Fcenters.dadabhagwan.org%2Fwp-content%2Fplugins%2Fsocial-connect%2Fgoogle%2Fconnect.php&openid.assoc_handle=AOQobUfydp3sIC8ptk9dyiKPbpvbbBr_mIwFTdp3x7k4w3qDczOER4Pt&openid.signed=op_endpoint%2Cclaimed_id%2Cidentity%2Creturn_to%2Cresponse_nonce%2Cassoc_handle%2Cns.ext1%2Cext1.mode%2Cext1.type.namePerson_first%2Cext1.value.namePerson_first%2Cext1.type.contact_email%2Cext1.value.contact_email%2Cext1.type.namePerson_last%2Cext1.value.namePerson_last&openid.sig=SZCPv4v4JLaZCUllR6QBizo3mw0%3D&openid.identity=https%3A%2F%2Fwww.google.com%2Faccounts%2Fo8%2Fid%3Fid%3DAItOawka1BDRCnbxBQjg9pVZrKH5Nl9q9MjJdx4&openid.claimed_id=https%3A%2F%2Fwww.google.com%2Faccounts%2Fo8%2Fid%3Fid%3DAItOawka1BDRCnbxBQjg9pVZrKH5Nl9q9MjJdx4&openid.ns.ext1=http%3A%2F%2Fopenid.net%2Fsrv%2Fax%2F1.0&openid.ext1.mode=fetch_response&openid.ext1.type.namePerson_first=http%3A%2F%2Faxschema.org%2FnamePerson%2Ffirst&openid.ext1.value.namePerson_first=Jinesh&openid.ext1.type.contact_email=http%3A%2F%2Faxschema.org%2Fcontact%2Femail&openid.ext1.value.contact_email=vorajinesh%40gmail.com&openid.ext1.type.namePerson_last=http%3A%2F%2Faxschema.org%2FnamePerson%2Flast&openid.ext1.value.namePerson_last=Vora

    Please guide me where i m doing mistake...waiting for reply.

    Regards,
    Jinesh

  7. vorajinesh@gmail.com
    Member
    Posted 3 years ago #

    Hello thenbrent,

    I just found that it works ..the only problem was, i was not trying with https ...once i tried with https, it worked well.

    Thanks for such a nice plugin ...

    Thanks and Regards,
    Jinesh

Topic Closed

This topic has been closed to new replies.

About this Topic