WordPress.org

Ready to get started?Download WordPress

Forums

Social Connect
Social Connect and Simple Press, or remove Social Connect from a specific page (4 posts)

  1. stevivor
    Member
    Posted 2 years ago #

    Hey! I'm running Simple Press for a forum on my WP blog, and the Social Connect buttons aren't working exactly as they should.

    Link here: http://stevivor.com/forums

    Basically, the Social Connect buttons above the forums don't redirect back properly (they work fine elsewhere on the site); they DO work if you click "Login" or "Register" on the blue bar under the Social Connect links and you then use the SC links on the Simple Press page. (Hope that made sense.)

    Can this be made to work, or alternatively, can I remove the "Connect with" buttons on this particular page?

    Thanks in advance!

    Cheers,
    Steve

    http://wordpress.org/extend/plugins/social-connect/

  2. Brostory
    Member
    Posted 1 year ago #

    I got the same question and would like to remove "connect with". Any help appreciated!

  3. lukewarmmizer
    Member
    Posted 1 year ago #

    You need to set $display_label = false in the sc_render_login_form_social_connect() function. This is done in the widget, however by default it is enabled on the login page. You could get around this by removing the default actions in functions.php, and then re-adding them with a call to a custom function that passes in the value, so...

    remove_action( 'login_form',          'sc_render_login_form_social_connect');
    remove_action( 'register_form',       'sc_render_login_form_social_connect');
    remove_action( 'after_signup_form',   'sc_render_login_form_social_connect');
    remove_action( 'social_connect_form', 'sc_render_login_form_social_connect');
    function no_label_social_connect(){
        sc_render_login_form_social_connect( array( 'display_label' => false ) );
    }
    add_action( 'login_form',          'no_label_social_connect', 10 );
    add_action( 'register_form',       'no_label_social_connect', 10 );
    add_action( 'after_signup_form',   'no_label_social_connect', 10 );
    add_action( 'social_connect_form', 'no_label_social_connect', 10 );

    Untested, but should work ;)

  4. lukewarmmizer
    Member
    Posted 1 year ago #

    And @stevivor - you probably need to set a hidden input value for redirect_to on the login form not located on the login/register page.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic