WordPress.org

Ready to get started?Download WordPress

Forums

Social
Social and reCAPTCHA (4 posts)

  1. CLS4690
    Member
    Posted 1 year ago #

    I'm using Social to aggregate social posts and to allow people to comment using a social media login. I'm also using WP recaptcha to require a reCAPTCHA when commenting, but the two plugins are getting in each other's way.

    The comment form is fine in the beginning. People who use their name, email, and type out a regular comment also see the reCAPTCHA form below that form, and are able to complete all parts of the forms in one shot.

    The problem results when someone logs in via Facebook/Twitter to post. The reCAPTCHA actually goes away after they log in, and then when the comment is entered and submitted, then reCAPTCHA returns an error, the reCAPTCHA then shows up, and commenters have to fill in the reCAPTCHA (for the first time) and submit.

    In addition, the post to twitter/post to facebook checkbox is almost completely hidden (until you press submit the first time and reCAPTCHA shows up.

    Any suggestions or code to paste somewhere would be greatly appreciated.

    http://wordpress.org/extend/plugins/social/

  2. sociallys
    Member
    Posted 7 months ago #

    I'm also curious about this..any word?

  3. Alex King
    Member
    Plugin Author

    Posted 6 months ago #

    I don't believe any effort has been made to make these two plugins work together. I'm sure it's possible if someone wants to debug and provide the appropriate patches to either/both plugins.

  4. MichelP
    Member
    Posted 5 months ago #

    Hi,
    I recently installed Social 2.9.2 on my blog and realized a bit later that it was not what I was looking for. So I uninstalled it. Though I did this through the dashboard, using the uninstall link of the plugin, the fields "Name", "Mail" and "website" keep appearing on my posts, just above the reCaptcha form. I tried to handle this by uninstalling other plugins I thougth could be in conflict with it but it didn't solve anything.

    I don't see how to get these fields out at all, and as I'm not programer (so don't know php...) it's a bit more complicated for me.
    I appreciate any help on this issue.

    The blog is here.

    Thanks in advance.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic