WordPress.org

Ready to get started?Download WordPress

Forums

Sociable/Stumbleupon problem (7 posts)

  1. Showgirl
    Member
    Posted 7 years ago #

    I've recently installed Sociable and my stumbleupon link doesn't work. I get the page not found screen come up and the url it goes to is http://www.stumbleupon.com/url/http%3A%2F%2Fwww.lolafayemi.com%2Findex.php%2F2007%2F06%2F27%2Fwere-human-its-official%2F. My website is at http://www.lolafayemi.com - does anyone know why this is happening?

  2. BlakkJakk
    Member
    Posted 7 years ago #

    I have similar but slight variation on the same problem. Mine comes up as

    The requested URL /url/http://www.blackjackskanz.com/index.php/?p=31 was not found on this server.

    For me, I think it is the /url at the start that is breaking it. At first it was droping the /index.php/ before ?p=31 which I solved by changed the URL to my blog under Options from http://www.blackjackskanz.com to http://www.blackjackskanz.com/index.php (not the URL to WordPress, that would do bad things).

    But I am still getting that strange stray /url/. From what I read from another post, it looks like a problem with WP 2.2 and Sociable but the author is not replying to emails.

    Hopefully the author updates or someone shares a solution. If you find out the solution let me know.

  3. Showgirl
    Member
    Posted 6 years ago #

    I'm still having this problem, does anyone know how I can fix it?

  4. dronerebel
    Member
    Posted 6 years ago #

    Had the same problem. This helped:
    WordPress Sociable Fix

    From the page:

    I’ve spotted a bug in the current version of the plugin (version 2.0) which prevents people from bookmarking your posts to StumbleUpon. If anyone tries to bookmark a page to StumbleUpon they will be taken to an invalid URL. The problem is with the following piece of code in sociable.php

    'StumbleUpon' => Array(
    'favicon' => 'stumbleupon.png',
    'url' => 'http://www.stumbleupon.com/url/PERMALINK‘,

    To fix the problem, change the above code to this:

    'StumbleUpon' => Array(
    'favicon' => 'stumbleupon.png',
    'url' => 'http://www.stumbleupon.com/submit/?url=PERMALINK&title=TITLE',

    You may want to temporarily disable the plugin whilst you make this change.

  5. ImageGag
    Member
    Posted 6 years ago #

    Works like a charm! Thank you dronerebel.

  6. Chromatic
    Member
    Posted 6 years ago #

    Thank you for this fix, awesome.

  7. Joost de Valk
    Member
    Posted 6 years ago #

    I "hijacked" the Sociable plugin for a new release, and fixed this as well as a lot of other stuff.

Topic Closed

This topic has been closed to new replies.

About this Topic