WordPress.org

Ready to get started?Download WordPress

Forums

sociable Plugin Not showing up in posts.. (9 posts)

  1. ebayqueen
    Member
    Posted 5 years ago #

    I am having an issue with http://www.asktheebayqueen.com I have read the other support pages first, and they have not resolved my issue. I can get sociable to show up on my pages but not my posts. Any idea what I can do?

    Thanks for the help!

    Suzie

  2. stvwlf
    Member
    Posted 5 years ago #

    Hi

    There is a setting on the Sociable admin page to tell it to not automatically insert its code. Then you have to insert a line of code yourself in the template files. The line to insert is in the plugin instructions, or on the plugin website, don't remember which.

    I've corrected an issue like this on several sites by manually inserting the plugin code. Then it appears exactly where you want it to display. You might give it a try.

  3. Joost de Valk
    Member
    Posted 5 years ago #

    What could cause it is two things:

    A: you don't have the correct box checked in the plugin admin page
    B: your theme doesn't correctly handle the post content, for instance echoes out post->post_content directly instead of through the_content.

    If you could copy paste the contents of your single.php template, we can have a look. If you don't have a single.php template, copy the index.php template's content.

  4. embarkcreative
    Member
    Posted 5 years ago #

    Same problem as ebayqueen. Have done as much trouble shooting as I'm aware of. I'm using template: MistyLook 3.7.2 by Sadish.

    Here is the code from my single.php template (is it resolvable?):

    <?php get_header();?>
    <div id="content">
    <div id="content-main">
    <?php if (have_posts()) : ?>
    <div class="postnav">
    <div class="alignleft"><?php previous_post_link('« %link') ?></div>
    <div class="alignright"><?php next_post_link('%link »') ?></div>
    </div>
    <?php while (have_posts()) : the_post(); ?>
    <div id="post-<?php the_ID(); ?>" <?php if (function_exists('post_class')){ post_class(); } else { echo 'class="post"' ;} ?>>
    <div class="posttitle">
    <h2>" rel="bookmark" title="<?php _e('Permanent Link to','ml');?> <?php the_title(); ?>"><?php the_title(); ?></h2>
    <p class="post-info"><?php the_time(__('M jS, Y','ml')) ?> <?php _e('by','ml');?> <?php the_author_posts_link() ?> <?php edit_post_link(__('Edit','ml'), '', ' | '); ?> </p>
    </div>
    <div class="entry">
    <?php the_content(); ?>
    <?php wp_link_pages(); ?>
    <p class="postmetadata">
    <?php if (function_exists('the_tags')) the_tags(__('Tags: ','ml'), ', ', '
    '); ?> </p>
    </div>
    <p class="postmetadata"><?php _e('Posted in','ml');?> <?php the_category(', ') ?></p>
    </div>
    <?php comments_template(); ?>
    <?php endwhile; ?>
    <?php else : include_once(TEMPLATEPATH.'/notfound.php');?>
    <?php endif; ?>
    </div><!-- end id:content-main -->
    <?php get_sidebar();?>
    <?php get_footer();?>

  5. farsightedrunner
    Member
    Posted 5 years ago #

    Hi Joost,

    Same problem as ebay queen.

    I know that the culprit is not option A, so I am guessing the problem is with option B.

    I am posting my single.php template below.

    Many thanks for any help that you can offer!

    <?php get_header();?>
    
    				<?php if (have_posts()) : while (have_posts()) : the_post(); ?>
    						<div class="post-nav">
    							<div class="left">
    								<?php previous_post_link('&laquo; %link') ?>
    							</div><!-- end "left" -->
    							<div class="right">
    								<?php next_post_link('%link &raquo;') ?>
    							</div><!-- end "right" -->
    							<div class="clear"/></div>
    						</div><!-- end "post-nav" -->
    							<div class="post">
    								<div class="post-tags"><?php the_tags('<p>', ', ', '</p>'); ?></div>
    									<div class="post-title" id="post-<?php the_ID(); ?>">
    										<h3><?php the_title(); ?></h3>
    									</div> <!-- end "post-title" -->
    								<div class="post-sup">
    									<span class="post-date"><?php the_time('l, F jS, Y') ?> - <?php the_time() ?> - <?php the_category(', ') ?></span>
    								</div><!-- end "post-sup" -->
    								<div class="post-entry">
    									<?php the_content('<p class="serif">Read the rest of this entry &raquo;</p>'); ?><br />
    									<?php wp_link_pages(array('before' => '<p><strong>Pages:</strong> ', 'after' => '</p>', 'next_or_number' => 'number')); ?>
    								<div class="post-footer">
    									<span class="post-edit"><?php edit_post_link('Edit this entry.','',''); ?></span>
    								</div><!-- end "post-footer" -->
    				<?php endwhile; ?>
    				<?php else : ?>
    					<h3 class="center">Not Found</h3>
    						<p class="center">Sorry, but you are looking for something that isn't here.</p>
    						<?php include (TEMPLATEPATH . "/searchform.php"); ?>
    				<?php endif; ?>
    
    					</div><!-- end "post-entry" -->
    			</div><!-- end "post" -->
    		</div><!-- end "top-primary" -->
    	</div><!-- end "wrapper-top" -->
    			<div id="top-secondary"><?php get_sidebar(); ?></div>
    				<div class="clear"></div>
    			</div><!-- end "top-secondary" --> 
    
    		<div id="page-bottom">
    		<div id="wrapper-bottom">
    		<div id="bottom-primary">
    					<div id="post-comments">
    						<?php comments_template(); ?>
    					</div>
    				<div id="prev-posts-footer">
    					<span class="nav-prev">
    						<?php previous_post_link('%link') ?>
    					</span>
    					<span class="nav-next">
    						<?php next_post_link('%link') ?>
    					</span><br class="clear"/>
    				</div><!-- end "prev-posts-footer" -->
    					<div id="archives">
    						<ul class="archlist-left">
    							<?php if (function_exists('compact_archive')) { /*if we have the compact archives plugin installed, we display it. If not we do the default <li> monthly archives */
    							compact_archive($style='block'); }
    							else { wp_get_archives('type=monthly'); } /* we do that here. Comment out the lines between the <div> tags to show nothing at all, or replace it with your own template tag. */ ?>
    						</ul>
    					</div><!-- end "archives" -->
    		<?php get_footer(); ?>
  6. farsightedrunner
    Member
    Posted 5 years ago #

    An update:

    Not sure what I did, but it is working perfectly now! :)

    Thanks for the great plug-in!

  7. RobbieHarris
    Member
    Posted 5 years ago #

    Having same issue using the ProCut 2 v.1.0 theme, its single.php is:

    <?php get_header();?>
    
    <div id="main">
          <div id="contentArea">
    		<?php if (have_posts()) : while (have_posts()) : the_post(); ?>
    
    <div class="post" id="post-<?php the_ID(); ?>">
    
    <div class="posttitle">
    <a href="<?php the_permalink() ?>" rel="bookmark" title="Permanent Link to <?php the_title(); ?>"><?php the_title(); ?></a>
    </div>
    
    <span class="post-info">
    <?php the_time('M jS, Y') ?> by <?php the_author_posts_link() ?> | <?php edit_post_link('Edit', '', ' | '); ?> <?php comments_popup_link('No Comments »', '1 Comment »', '% Comments »'); ?>
    </span>
    
    <div class="entry">
    <?php the_content('Continue Reading &raquo;'); ?>
    <?php wp_link_pages(); ?>
    </div>
    
    <p class="postmetadata">
    Posted in <?php the_category(', ') ?> | <?php comments_popup_link('No Comments »', '1 Comment »', '% Comments »'); ?></p>
    
    </div><!--end post-->
    <?php comments_template(); ?> 
    
    <?php endwhile; else: ?>
    			<p><?php _e('Sorry, no posts matched your criteria.'); ?></p>
    		<?php endif; ?>
          </div>
    
    <?php get_sidebar();?>
    </div>
    <?php get_footer();?>
  8. RobbieHarris
    Member
    Posted 5 years ago #

    Erm, like the previous post its all working like a charm and i've done nothing except leaving it alone and then going back to my site a few hours later... How odd.

  9. artfool
    Member
    Posted 4 years ago #

    Same problem here, no matter where I've tried pasting in the code nothing works. It will show up on individual pages, etc.

    <?php
    /**
     * @package WordPress
     * @subpackage Default_Theme
     */
    
    get_header();
    ?>
    
    	<div id="content" class="narrowcolumn" role="main">
    
    	<?php if (have_posts()) : while (have_posts()) : the_post(); ?>
    
    		<div <?php post_class() ?> id="post-<?php the_ID(); ?>">
                	<div class="post_date">
                        <span class="day"><?php the_time('d') ?></span><br />
                        <span class="month"><?php the_time('M') ?></span><br />
                        <span class="year"><?php the_time('Y') ?></span>
                    </div>
    
                    <div class="post_content">
    
                        <h2><a href="<?php the_permalink() ?>" rel="bookmark" title="Permanent Link to <?php the_title_attribute(); ?>"><?php the_title(); ?></a></h2>
    
                        <div class="entry">
                            <?php the_content('Read the rest of this entry &raquo;'); ?>
                        </div>
    
                    <p class="postmetadata"><?php the_tags('Tags: ', ', ', '<br />'); ?> Posted in <?php the_category(', ') ?> </p>
    
                    </div>
    		</div>
    
        <div class="comments_content">
    	<?php comments_template(); ?>
        </div>
    
    	<?php endwhile; else: ?>
    
    		<p>Sorry, no posts matched your criteria.</p>
    
    <?php endif; ?>
    
    	</div>
    <?php get_sidebar(); ?>
    <?php get_footer(); ?>

Topic Closed

This topic has been closed to new replies.

About this Topic