WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
[resolved] So. Um. sitemap_index.xml file is now "hidden" ? (2 posts)

  1. hpwtexas
    Member
    Posted 1 year ago #

    WordPress version: 3.5.1
    WordPress Theme: Mantra v1.9.9.6
    WordPress SEO version:1.3.4.4
    (PHP5)

    On Friday, 2/8, Google search results looked great. Discovered https:// indexing issue(ssl set up for https//site.com, not https//www.site.com, so requesting https//www.site.com returns an error). Began troubleshooting via .htaccess; no dice. Requested url removal for https//www.site.com, would return to the issue after the weekend.

    On Monday, 2/11, Google search results are now ALL GONE (#facepalm). Initially, the previous url removal request was suspected as cause; realized this was likely a sitemap issue.

    > Reviewed Yoast settings >> reviewed root/sitemap_index.xml--returned as 404. Crap. Accessed root/ via ftp; root/sitemap_index.xml IS indeed confirmed missing. Begain troubleshooting.
    > Reviewed Yoast settings again >> disabled/reenabled Yoast sitemap function; no change. Disabled/reenabled Yoast plugin; no change. Researched forums and support threads--no solution found; my situation *appears* to be unique.
    > Reviewed WP-Super Cache settings >> disabled preload; no change. Disabled plugin all together; no change.
    > Reviewed WP Security Scan settings >> On a whim, I returned table prefixes to default prefix(wp_) via WP Security Scan; no change. Of course.
    > Reviewed Yoast settings once more >> Disabled/reenabled Yoast plugin again; and now this is where it gets weird. Currently, when requesting site.com/sitemap_index.xml, the returned page appears blank. Viewing the source reveals what appears to be the proper sitemap_index for the website. Testing the sitemap via webmastertools returns no errors as well. However, when requesting site.com/sitemap_index.xml via FTP, xml files are NON-EXISTANT! Requested sitemap via browser to double check--yep. This is officially weird. If it'd help to see what the hell I'm talking about, here's the "Hidden" sitemap url : http://hpwtx.com/sitemap_index.html

    #sigh.
    Thanks,

    * Other plugins in use (I'm a newbie--don't judge):
    AWD Weight/Country Shipping v1.0.1
    Custom Widget Area v1.1
    Jetpack by WordPress.com v2.1.2
    Media Library Assistant v1.11
    Menu Items Visibility Control v0.2.1
    Regenerate Thumbnails v2.2.4
    Slick Sitemap v1.0.0
    WooCommerce v1.6.6
    WooCommerce Chase Paymentech Gateway v1.2
    Woocommerce CSV Import v0.7.1 (update pending)
    WooCommerce Customizer v1.0.0
    WooCommerce Grid / List toggle v0.3 (update pending)
    WordPress SEO by Yoast v1.3.4.4
    WP-DBManager v2.63
    WP-PageNavi v2.83
    WP Security Scan v3.0.9
    WP Super Cache v1.2

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. hpwtexas
    Member
    Posted 1 year ago #

    Resolved. That was fun.
    So here's what happened:
    I read this thread: http://wordpress.org/support/topic/plugin-wordpress-seo-by-yoast-sitemap-is-blank-page?replies=18
    (change site url settings; http, https, www, non-www, etc.)

    And you know what, if you have ssl then you needa be REALLY damn careful with what you put in those two fields. Ended up breaking the site for about five minutes. Resolved THAT problem by coming accross this thread: http://wordpress.org/support/topic/changed-blog-url-cant-log-in-now?replies=12 which pointed me to this codex topic: http://codex.wordpress.org/Changing_The_Site_URL#Edit_functions.php

    So. Had to set my urls to: https//site.com
    While I'd really rather not have the entire site on https, the sitemap works perfectly--and all my search results came back automagically. So no reason to whine here.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic