WordPress.org

Ready to get started?Download WordPress

Forums

Code Snippets
[resolved] Snippets prevents permalink edits? (6 posts)

  1. Taloscent
    Member
    Posted 8 months ago #

    confirmed when plugin is disabled I can change the permalink of a post or page but when enabled I can not. Any ideas?
    Thank you

    http://wordpress.org/plugins/code-snippets/

  2. Shea Bunge
    Member
    Plugin Author

    Posted 8 months ago #

    That's strange. Nothing in this plugin should be interfering with the post edit screen, or post permalinks.

    On my WordPress site which uses Code Snippets, I can edit a post, alter the permalink by clicking the Edit button, entering in a new name, clicking OK and updating the post. The permalink is changed successfully.

    Can you walk me through exactly what you're trying to do when changing the permalink?

  3. Taloscent
    Member
    Posted 8 months ago #

    I have deactivated all other plugins. I got to any given page and try to change the permalink by just adding a letter or number and when I click OK it just sits there. No page refresh, no changes. I have tried it with the default 2012 theme and the behavior is the same.

    I suspect it is due to some changes that were made using Better WP Security. I am not sure. Even deactivating Better WP Security did not make a change.

  4. Shea Bunge
    Member
    Plugin Author

    Posted 8 months ago #

    I'm wondering if anyone else is having this issue … ? Do you have any snippets activated? Perhaps they could be messing something up, instead of the Code Snippets plugin.

  5. Taloscent
    Member
    Posted 8 months ago #

    I have 2 simple snippers
    1
    function TuitionOEOEShortcode() {
    return '<p>$2.00</p>';
    }
    add_shortcode('tuitionoeoe', 'TuitionOEOEShortcode');

    function TuitionLockstepShortcode() {
    return '<p>$1.70</p>';
    }
    add_shortcode('tuitionlockstep', 'TuitionLockstepShortcode');

    2
    function email_encode( $atts, $email ){
    return ''.antispambot($email).'';
    }
    add_shortcode( 'email', 'email_encode' );

  6. Taloscent
    Member
    Posted 8 months ago #

    OK found the problem. I had some code in a 3rd one that was conflicting with the theme's custom css entry.

    Solved for now! Thank you for the quick response and encouragement.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.