WordPress.org

Ready to get started?Download WordPress

Forums

WP Smush.it
[resolved] [closed] Smush.it doesn't bulk smush! (19 posts)

  1. Peter Stolwijk
    Member
    Posted 10 months ago #

    Hello friends,

    The problem i have is that i want to smush 4000 images.
    But the bulk Smush does not work, only if i smush it one by one.

    Please note, i do not use a CDN, but do use Yoast Seo.
    Im also not using any cache plugins.

    So what't the best i can do or can have it work?

    Thank you!

    http://wordpress.org/plugins/wp-smushit/

  2. WPMUDEV
    WPMU DEV Support Staff
    Plugin Author

    Posted 10 months ago #

    Peter Stolwijk,

    Well I know 4000 images it a lot and admittedly, the bulk processing needs some work to provide a way to back process older images. I'm sure you will hit a timeout. But I have two thoughts.

    1. Go to Settings > Media. On that page look for the Smush.it section. Try setting the timeout very high like 300 seconds (5 minutes). Then go to Media > Bulk ad try and see how many images will be processed. You might get as far as 1000 if you are lucky. If you then try Media > Bulk again it should skip the already processed image very quickly.

    2. IF the above does not work then again try setting the timeout very high. Then go to Media > Library. In the top-right of the screen click the Screen Options tabs. Then set the number of images to show page page to something higher than the default 20. Try maybe 100. Once the page reloads use the checkbox in the first column to select all the images. The from the action dropdown menu above the table select Bulk. Then click the button next to the drop down. It will take some time but eventually you should make it through the 4000 images.

  3. Peter Stolwijk
    Member
    Posted 10 months ago #

    This is what it says:

    We found 2736 images in your media library. Be forewarned, it will take at least 136 minutes to process all these images if they have never been smushed before.

    Even after i deleted 1300 posts!

    Does this mean that i need to change the settings to 60x136=8160 seconds?

    Anyway, i think that wouldn't be a problem.
    But the problem is, that i receive every three minutes automatic a new photo to my media. Even after i selected automatically process on upload, the photos are not automatically smushed before it appaears in my library/media.

    How come?
    Thank you!

  4. WPMUDEV
    WPMU DEV Support Staff
    Plugin Author

    Posted 10 months ago #

    Peter Stolwijk,

    We found 2736 images in your media library. Be forewarned, it will take at least 136 minutes to process all these images if they have never been smushed before.

    Even after i deleted 1300 posts!

    IF that is what it says then that is how many images you have. Again the plugin simply reads your Media > Library. So if you go to Media > Library you should find the same number of images.

    But the problem is, that i receive every three minutes automatic a new photo to my media. Even after i selected automatically process on upload, the photos are not automatically smushed before it appaears in my library/media.

    How are these new images added to your library? The Smush.it plugin by hooking into the media upload action.

  5. Peter Stolwijk
    Member
    Posted 10 months ago #

    Thank you!

    Automatic with robot rss feed

  6. Peter Stolwijk
    Member
    Posted 10 months ago #

    well ?? Does this give any added information?

  7. Mike
    WPMU DEV Support Staff
    Posted 10 months ago #

    So the RSS feed imports the images to your library? If this is the case then the images will not be smushed as you are not using the uploader.

    You can bulk smush them once they are there but they won't be smushed automatically.

  8. Peter Stolwijk
    Member
    Posted 10 months ago #

    Thank you Mike!
    But the smush won't work either, when they are in the library.

    It hangs, it only works when i smush it one by one.

    400 pictures a day, so this plug-in is not made for me i gues.
    Thank you!

  9. Mike
    WPMU DEV Support Staff
    Posted 10 months ago #

    You have quite a lot of images don't you!

    Have you tried altering the value in: "How many seconds should we wait for a response from Smush.it?"

    It could be that you just have too many images for the smush.it service to handle I guess.

  10. Peter Stolwijk
    Member
    Posted 10 months ago #

    Yeah i gues i have a lot of images my friend.
    I have a news site, so alot of posts goes with images.

    Have you tried altering the value in: "How many seconds should we wait for a response from Smush.it?"

    No, where can i do this?

  11. Mike
    WPMU DEV Support Staff
    Posted 10 months ago #

    Settings > Media

    If you increase or decrease the time it might stop it timing out.

  12. Peter Stolwijk
    Member
    Posted 10 months ago #

    I already tried to set it to 300, but don't have any impact!
    Can i set it to 30.000 seconds?

  13. Peter Stolwijk
    Member
    Posted 10 months ago #

    I really think im deleting this plug-in.

    I mean ok, rss images won't smush automatically, i accept that.
    But it would not even smush bulk or one by one, when the images are already in the library.

    This is what i get:

    Processing 201310eae22__557315…
    — [original] 0 x 0: N

    Processing 2013103b07f__557329…
    — [original] 0 x 0: N

    Processing 2013103e4a7__556658…
    — [original] 0 x 0: N

    Smush.it finished processing.

    And when i go to the library again, the image is still Not processed or not smushed

  14. Mike
    WPMU DEV Support Staff
    Posted 10 months ago #

    Maybe it isn't importing the images properly, do they show with the correct file sizes in the Media Library?

    Have you tried reducing the the value to something much lower? Maybe 5 seconds?

    It might be trying to smush images that have incorrect sizes in the database.

    If this doesn't change anything it could just be that the smush.it service just can't handle the number of images :-/

  15. Peter Stolwijk
    Member
    Posted 10 months ago #

    Mike you are a great guy!

    But i think this all won't work.
    I've tried to change time in media settings from 300 to 5 seconds, but no results.

    This plugin won't smush rss jpg images. Other images that i upload manually does work.

  16. Mike
    WPMU DEV Support Staff
    Posted 10 months ago #

    It's something to do with them not being properly imported to the media library clearly.

    Thanks for letting us try and help at least.

  17. ADakota2013
    Member
    Posted 9 months ago #

    I get a repeated debug error with filename path, then status is "Did not Smush.it due to previous errors" - but i have no idea what the previous error is! It is trying to smush approx 305 images, I have increased the timeout (as noted in prev posts) and still bulk does not work.
    It worked on about 3 images in the past. but that's it.
    any suggestions?
    AD

  18. ADakota2013
    Member
    Posted 9 months ago #

    oopps i probably should have started a new thread for this?

  19. Hi there @ADakota2013,

    Greetings and thanks for getting in touch.

    If you could open a new thread please, that will keep it cleaner and easier to manage each issue :)

    We look forward to assisting you!

    Kind Regards
    Jack.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags