WordPress.org

Ready to get started?Download WordPress

Forums

WP Smush.it
[resolved] Smush.it Breaks Page When Activated (8 posts)

  1. Gail
    Member
    Posted 1 year ago #

    I was following this WordPress Optimization Guide that uses the W3 Total Cache and Smush.it to optimize my WordPress blog. After following the instructions, and bulk smushing my image library, my page went from 78/69 to 100/100. I was amazed. I went from a 3.63 second page load time to a 0.35 second page load time. I was never able to accomplish this with W3 Total Cache alone.

    However, when I checked my page in other browsers and then emptied the browser cache of my current browser, my page wouldn't appear at all. I immediately went back and deactivated Smush.it. My site immediately loaded once I deactivated Smush.it.

    My page is still getting a score of 100/100 with Smush.it deactivated, but it would seem I will have to activate it whenever I add an image to my image library in order to retain the benefits of the plugin. Obviously, this is not how the plugin was designed to work and will be time intensive compared to having it running in the background.

    It is not a W3 Total Cache problem. It is only a problem when Smush.it is activated. Here is a link to my site:

    http://dappledthings.me/

    Is there something that can be done to remedy this problem? Thanks.

    http://wordpress.org/extend/plugins/wp-smushit/

  2. Gail
    Member
    Posted 1 year ago #

    Now I just don't understand what's going on. I refreshed my browser caches in Chrome, IE, and Firefox and my page wouldn't appear once again. So, I deactivated W3 Total Cache and now my page is back. What am I doing wrong?? I followed the directions here, so you can see what settings I enabled. I also have CloudFlare enabled since I use it. I disabled the Smush.it plugin as I said earlier. Can someone look at the optimization guide and look at my blog and see what I might be doing wrong. My page score is back to 77/69 without W3 Total Cache and Smush.it. Please help!

  3. Gail
    Member
    Posted 1 year ago #

    It appears that Smush.it wasn't the problem at all. There appears to be a problem with the newest version of the W3 Total Cache with the Page Cache Debug mode being on. My apologies. Smush.it works fine. Thanks!

  4. bottleneck
    Member
    Posted 1 year ago #

    Hey.
    I took my time not willing to interfere thinking that Frederic would say his word. There is none yet so let me just ask.

    Your blog's source page is filled up with W3 Total Cache stuff. There are thousands lines of code. I guess it called the Page Cache Debug mode.
    Sure enough, your site is slow. Are you able to turn it off?

    By the way, I am a fan of WP Super Cache.

  5. Gail
    Member
    Posted 1 year ago #

    I had to turn off Page Cache Debug mode to get my page to load. Apparently, this is a recent problem with W3 Total Cache, and I have started a conversation over at W3 Total Cache's support forum hoping to hear something soon. There are actually several recent pots about this problem over there. I am not the only one having this problem.

    Why are you a fan of WP Super Cache and have you ever used W3 Total Cache? Can you give a fair comparison?

  6. bottleneck
    Member
    Posted 1 year ago #

    Sure.

    There is a terrific manual.

    Suggested Settings

  7. Gail
    Member
    Posted 1 year ago #

    You didn't really answer all of my questions. There are awesome optimization guides for W3 Total Cache and even the Hostgator site you sent me to has one, although I wouldn't say either one of their settings guides for these two plugins is "terrific". :(

  8. Mike
    WPMU DEV Support Staff
    Posted 10 months ago #

    We're just looking over some old threads and I noticed this one.

    You've marked it as resolved which suggests you have sorted this, the Smush.it service is unfortunately not compatible with caching plugins.

    If you have any other problems then please post another topic and we'll help out ASAP :-)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic