WordPress.org

Ready to get started?Download WordPress

Forums

WP Smush.it
[resolved] Smush plugin runs but does not work (17 posts)

  1. Simonemottura
    Member
    Posted 8 months ago #

    hello,

    I am a photographer, I have a site full of photos. Yesterday I turned on this fantastic plugin.
    I started using Smush plugin to 20 photos at a time. Everything worked ...
    Then I tried with 500 (500 of 1700) photo at a time, no longer works.

    Today I discovered the bulk, for all the photos, fantastic, says 67 min.
    Unfortunately, nothing works!

    What should I do?

    I have the latest version of wordpress on mac.

    Thank you!

    http://wordpress.org/plugins/wp-smushit/

  2. WPMUDEV
    WPMU DEV Support Staff
    Plugin Author

    Posted 8 months ago #

    @Simonemottura,

    I have the latest version of wordpress on mac.

    Might be somewhat of a clue. When you say 'on mac' are you running WordPress on your local mac machine? Or is your hosting a Mac server?

    The difference is if you are running on your local laptop then Smush.it will not work since the Yahoo! service cannot access your images.

    In more detail. When you run the bulk Smush.it the plugin dents the URL for your image to the remote Yahoo! service. The service then uses the URL to access your image in order to perform the needed processing. So it is important that the image be available on the public internet.

  3. Simonemottura
    Member
    Posted 8 months ago #

    hello!
    Thanks for your interesting.
    my site is on the largest public italian hosting (name: ARUBA).
    I do not understand why for a little time it is worked.

    It stopped working when I decided that 20 pictures at a time, it was a job too long, and I have chosen to "screen options" 500 "media items".
    Now no longer works even if I only choose 20 photos ...
    I delete the plugin and reinstall?
    Thanks.

  4. WPMUDEV
    WPMU DEV Support Staff
    Plugin Author

    Posted 8 months ago #

    @Simonemottura,

    I delete the plugin and reinstall?

    No. Doubtful that will resolve anything.

    Try this. Go to Settings > Media. There you will see the section for the Smush.it plugin. Check the timeout value. What do you have there? Also there is a checkbox to enable debug output. Save the settings.

    Next go to Media > Library. Select a row for an item not previously smushed. Set the checkbox in the first column for that row. Above the listing you will see the drop down actions. Select 'Bulk Smish.it' from the drop down. Then click the apply button. This will bulk process the one selected image.

    This is NOT the same as clicking the smash.it option in the last column of the row.

    When the bulk smash.it runs you will see some debug output. Paste it back here for our review.

  5. Simonemottura
    Member
    Posted 8 months ago #

    Well!
    in SETTINGS:
    1- automatically process on upload
    2- 60 seconds
    3- checkbox not selected "If you are having trouble with the plugin enable this option can reveal some information about your system needed for support."
    Should I change something ?

    in MEDIA:
    "Select a row for an item not previously smushed. Set the checkbox in the first column for that row. Above the listing you will see the drop down actions. Select 'Bulk Smish.it' from the drop down. Then click the apply button. This will bulk process the one selected image."
    Well! That is my procedure for 500 photos that created the block.

    Now, if I selected a 4-5 media it's run... but I have 1,157 media...
    Thanks!

  6. Simonemottura
    Member
    Posted 8 months ago #

    I don't know...
    I think it's a yahoo problem, I had two tests within a few minutes with 15 photos , the first time it blocked, the second ran.

  7. WPMUDEV
    WPMU DEV Support Staff
    Plugin Author

    Posted 8 months ago #

    @Simonemottura,

    Yeah, Yahoo! has some service restrictions. If they think you are trying to push through too many images to process they will throttle your request. nothing much can be done about it. And at the moment there is no background or automated processing.

  8. Simonemottura
    Member
    Posted 8 months ago #

    Sorry , but there is some other plugin that does a similar job ?
    The settings in the "settings" is correct?

  9. WPMUDEV
    WPMU DEV Support Staff
    Plugin Author

    Posted 8 months ago #

    @Simonemottura,

    but there is some other plugin that does a similar job ?

    Feel free to search for them. I'm not aware of any other plugins which use the Yahoo Smush.it service API. There are a few other plugin which do this image optimization locally on your server. But those require you have certain PHP and server libraries installed for the image manipulations.

    The settings in the "settings" is correct?

    you might consider increasing the value for the timeout from 60 seconds to 120. But still there are going to be issues with the Yahoo! service blocking you from using the API after too many images are processed. We don't have any control over the blocking.

  10. Simonemottura
    Member
    Posted 8 months ago #

    So there is no resolution to this problem , right?
    wait a few days and then try some photos may be useful ?

  11. WPMU DEV
    Member
    Posted 8 months ago #

    Hi @Simonemottura,

    Are you running Varnish or using any caching plugin?

    Can you try enabling WP_DEBUG mode and debug logging? To do this, just go to wp-config.php include this:

    define('WP_DEBUG',true);
    define('WP_DEBUG_LOG',true);

    You might already have a line for WP_DEBUG, so just make sure it's set to true. This will create a log file under wp-content/debug.log with detailed information.

    If you'd like to avoid end users seeing error messages, you can include this as well:

    @ini_set('display_errors',0);
    define('WP_DEBUG_DISPLAY', false);

    This will prevent errors from being displayed, but you can still find them in the log file. For information on this, checkout this wpmu.org article.

    Let me know what errors if any you are getting!

    Regards,

  12. WPMUDEV
    WPMU DEV Support Staff
    Plugin Author

    Posted 7 months ago #

    Hey there.

    We haven't heard from you in awhile, so I just wanted to check in to make sure all was good.

    This thread was marked resolved, but please, if you still need help then just respond and open it back up. We can then take it from there. :)

    Hope you have a fantastic day!

  13. Simonemottura
    Member
    Posted 7 months ago #

    hello , I have not really solved.
    I've done other tests, but nothing has changed.

    I'm sorry! but I did not have time for this problem.

    The last your post, it is incomprehensible to me, because I have no experience as a webmaster.
    Thanks.

  14. WPMU DEV
    Member
    Posted 7 months ago #

    Hi @Simonemottura,

    In my last post, i have written all the steps that you should follow to enable debugging on your site along with some useful links which will provide you more detailed information on it so you don't need to have experience as a webmaster to implement it.

    Please advise specifically if you have questions regarding it.

    Best Regards,

  15. Simonemottura
    Member
    Posted 7 months ago #

    Hi!
    sorry, but I do not know what is debugging because it is not translated into Italian. :-(

    I did not realize I have to download and instalare the plugin called "WP DEBUG"?

    I'm sorry, I read the tutorial and I did not understand anything.
    On my site I have not customized. I do not want to lose the customizations made by the webmaster.

    Can I have a service without restriction by Yahoo for a fee ?

  16. Simonemottura
    Member
    Posted 7 months ago #

    sorry... installare = installing

  17. WPMU DEV
    Member
    Posted 7 months ago #

    Hi @Simonemottura,

    I did not realize I have to download and instalare the plugin called "WP DEBUG"?

    It's not a plugin it's a flag / constant to enable debugging.

    Can I have a service without restriction by Yahoo for a fee ?

    I don't know anything about such a service and as posted in previous reply , nothing much can be done about it.

    Instead of these you can try increasing wait response timeout value from the following path.

    Admin -> Settings -> Media -> WP Smush.it

    Also try bulk smushing images in smaller chunks than currently you are doing.

    Regards,

Reply

You must log in to post.

About this Plugin

About this Topic

Tags