WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] SMTP Settings for Go Daddy Email Accounts (10 posts)

  1. stevec828
    Member
    Posted 4 years ago #

    I did not see a concise explanation for configuring WP SMTP for Go Daddy hosting and email. Other posts helped, but here is what worked for me in one place:

    1) Install the WP-Mail-SMTP plug-in. Activate it.
    2) Enter your From Email and Name
    3) Setup the Mailer settings as follows:

    Mailer:
    * Use the PHP mail() function to send emails.

    SMTP Options
    SMTP Host: relay-hosting.secureserver.net
    SMTP Port: 25
    Encryption:
    * No encryption.
    Authentication:
    * Yes: Use SMTP authentication.

    4) Enter your valid email account credentials.
    Username:
    Password:

    5) Update options.
    6) Send test mail. You should get this result:
    Test Message Sent
    The result was:
    bool(true)

  2. chaoman
    Member
    Posted 3 years ago #

    Thanks a lot for the setting of Godaddy.

  3. spolito
    Member
    Posted 3 years ago #

    Tried what you said and I got bool(false).

    I also tried GoDaddy settings that I know work in a POP connected Outlook client. After that I tried settings that I know work for Gmail.

    One of those settings should have worked.

    How do I know if WP-Mail-SMTP works or is installed correctly?

    Any help would be greatly appreaciated.

    Thanks
    Steve

  4. spolito
    Member
    Posted 3 years ago #

    BTW, in your directions above, you say to use the "PHP mail()" which bypasses the SMTP options you typed in.

  5. GeoffreyG
    Member
    Posted 3 years ago #

    Hello,

    I've finally SOLVED this problem for myself and I wanted to post the solution I used! To make the WP Mail SMTP plugin work with my WordPress site hosted at GoDaddy, I had to use the following settings:

    Settings to make the WP Mail SMTP plugin work with GoDaddy Hosting:
    - From Email:
        GoDaddy hosting email address (from https://login.secureserver.net/index.php).
    - From Name:
        The name you want people to see in their email inbox.
    - Mailer:
        Select: "Send all WordPress emails via SMTP."
    - SMTP Host:
        smtpout.secureserver.net
    - SMTP Port:
        80
    - Encryption:
        Select: "No encryption."
    - Authentication:
        Select: "Yes: Use SMTP authentication."
    - Email:
        GoDaddy hosting email address (from https://login.secureserver.net/index.php).
    - Password:
        The password for the Email account above.

    And that should solve your problems, at least it solved mine! If you try to send a test mail from the WP Mail SMTP plugin settings page, you should get the message:

    Test Message Sent
    The result was:
    bool(true)
    ...
    ... Some debug output
    ...
    250 Accepted message qp 25961 bytes 794
    SMTP -> FROM SERVER:
    221 Good bye.

    History of this problem for me:
    When I setup my account at GoDaddy, I did not use the default c-panel WordPress install (but I don't think that makes a difference after reading other posts), but I actually uploaded the WordPress binaries to my GoDaddy hosting. I already had other WordPress sites through other hosting provides (where the default WordPress e-mail worked perfectly out of the box), but for some reason, the default WordPress e-mail does not work out of the box with GoDaddy hosting.

    I searched the problem and found many, many articles with people saying they had the same problem, most of them suggesting to use the WP Mail SMTP plugin. So, I tried that plugin, but alas, my problem was still not solved (mainly because I had the wrong settings for the plugin).

    I eventually found this post I saw this post and tried that same, but also had the same result as Spolito. When I tried to send the test mail with the settings that stevec828 provides:

    - Use the PHP mail() function to send emails.
    - SMTP Host: relay-hosting.secureserver.net
    - SMTP Port: 25
    - No encryption.
    - Yes: Use SMTP authentication.
    - Email: (my email for the GoDaddy site at https://login.secureserver.net/index.php)
    - Password: (For the above account)

    The test would fail and I would see the Debugging output:

    The SMTP debugging output is shown below:
    ...
    ... A bunch of setting information, the real output is at the bottom
    ...
    
    SMTP -> FROM SERVER:
    220 p3nlsmtp01.shr.prod.phx3.secureserver.net ESMTP
    SMTP -> FROM SERVER:
    250-p3nlsmtp01.shr.prod.phx3.secureserver.net
    250-PIPELINING
    250-SIZE 31457280
    250 8BITMIME
    SMTP -> ERROR: AUTH not accepted from server: 502 unimplemented (#5.5.1)
    
    SMTP -> FROM SERVER:
    250 flushed

    So, after searching on the 502 error, I was able to find this article:
    http://wordpress.org/support/topic/godaddy-wordpress-install-w-disabled-mail-function

    After trying Vivid's proposed solution (which is the settings I show at the top of this post), I was able to send WordPress e-mails using the WP Mail SMTP plugin via GoDaddy servers without a problem. I hope this helps you out :) ...

  6. sigdd
    Member
    Posted 3 years ago #

    GeoffreyG -

    You ROCK. I noodled around with this forever and finally found your post -- so following you settings above exactly, mine also worked. I found that when you don't have some of the settings quite right...it will come through once in a while - but it takes really long for the form to finish sending (which is annoying for the user) and then you don't get the email for a long time (as in, up to an hour). But with the settings from GeoffreyG's post above - it sends instantaneously and arrives lightning fast, as well.

    Just to make everything super clear - I'm copying/pasting the code again here:

    - From Email:
    Your GoDaddy hosting email address
    - From Name:
    The name you want people to see in their email inbox.
    - Mailer:
    Select: "Send all WordPress emails via SMTP."
    - SMTP Host:
    smtpout.secureserver.net
    - SMTP Port:
    80
    - Encryption:
    Select: "No encryption."
    - Authentication:
    Select: "Yes: Use SMTP authentication."
    - Email:
    Your GoDaddy hosting email address
    - Password:
    The password for the Email account above.

  7. entourage
    Member
    Posted 3 years ago #

    Wow! Greeeat! I searched the whole entire web for the right answers to this question here. And this forum was it! Thanks you guys

  8. ibrar0
    Member
    Posted 3 years ago #

    Hi All,
    I have very strange behavior, I have tried to setup all the options even gmail smtp settings but failed.
    following is the error log using godaddy's smtp settings

    Any help?. all suggestions are welcome.
    Thanks in advance.

    Test Message Sent
    wordpress Test mail to ibrar0@gmail.com
    
    The result was:
    
    See FAQ
    
    bool(false)
    
    The full debugging output is shown below:
    
    See FAQ
    
    object(PHPMailer)#30 (45) {
      ["Priority"]=>
      int(3)
      ["CharSet"]=>
      string(5) "UTF-8"
      ["ContentType"]=>
      string(10) "text/plain"
      ["Encoding"]=>
      string(4) "8bit"
      ["ErrorInfo"]=>
      string(43) "SMTP Error: Could not connect to SMTP host."
      ["From"]=>
      string(19) "info@gotbarking.com"
      ["FromName"]=>
      string(27) "WordPress Contact Form Test"
      ["Sender"]=>
      string(19) "info@gotbarking.com"
      ["Subject"]=>
      string(29) "Test mail to ibrar0@gmail.com"
      ["Body"]=>
      string(90) "This is a test mail generated by the Fast Secure Contact Form
    WordPress plugin. wordpress"
      ["AltBody"]=>
      string(0) ""
      ["WordWrap"]=>
      int(0)
      ["Mailer"]=>
      string(4) "smtp"
      ["Sendmail"]=>
      string(18) "/usr/sbin/sendmail"
      ["PluginDir"]=>
      string(0) ""
      ["Version"]=>
      string(5) "2.0.4"
      ["ConfirmReadingTo"]=>
      string(0) ""
      ["Hostname"]=>
      string(0) ""
      ["MessageID"]=>
      string(0) ""
      ["Host"]=>
      string(24) "smtpout.secureserver.net"
      ["Port"]=>
      string(3) "587"
      ["Helo"]=>
      string(0) ""
      ["SMTPSecure"]=>
      string(0) ""
      ["SMTPAuth"]=>
      bool(false)
      ["Username"]=>
      string(20) "admin@gotbarking.com"
      ["Password"]=>
      string(9) "*****(password)"
      ["Timeout"]=>
      int(10)
      ["SMTPDebug"]=>
      int(2)
      ["SMTPKeepAlive"]=>
      bool(false)
      ["SingleTo"]=>
      bool(false)
      ["smtp"]=>
      object(SMTP)#31 (7) {
        ["SMTP_PORT"]=>
        int(25)
        ["CRLF"]=>
        string(2) "
    "
        ["do_debug"]=>
        int(2)
        ["do_verp"]=>
        bool(false)
        ["smtp_conn"]=>
        bool(false)
        ["error"]=>
        array(3) {
          ["error"]=>
          string(27) "Failed to connect to server"
          ["errno"]=>
          int(10060)
          ["errstr"]=>
          string(185) "A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.
    "
        }
        ["helo_rply"]=>
        NULL
      }
      ["to"]=>
      array(1) {
        [0]=>
        array(2) {
          [0]=>
          string(16) "ibrar0@gmail.com"
          [1]=>
          string(0) ""
        }
      }
      ["cc"]=>
      array(0) {
      }
      ["bcc"]=>
      array(0) {
      }
      ["ReplyTo"]=>
      array(0) {
      }
      ["attachment"]=>
      array(0) {
      }
      ["CustomHeader"]=>
      array(3) {
        [0]=>
        array(2) {
          [0]=>
          string(8) "Reply-To"
          [1]=>
          string(20) " info@gotbarking.com"
        }
        [1]=>
        array(2) {
          [0]=>
          string(8) "X-Sender"
          [1]=>
          string(20) " info@gotbarking.com"
        }
        [2]=>
        array(2) {
          [0]=>
          string(11) "Return-Path"
          [1]=>
          string(20) " info@gotbarking.com"
        }
      }
      ["message_type"]=>
      string(5) "plain"
      ["boundary"]=>
      array(2) {
        [1]=>
        string(35) "b1_74da2d46485429b168372bc96c6f32ac"
        [2]=>
        string(35) "b2_74da2d46485429b168372bc96c6f32ac"
      }
      ["language"]=>
      array(13) {
        ["mailer_not_supported"]=>
        string(25) " mailer is not supported."
        ["provide_address"]=>
        string(55) "You must provide at least one  mailer is not supported."
        ["execute"]=>
        string(19) "Could not execute: "
        ["instantiate"]=>
        string(36) "Could not instantiate mail function."
        ["authenticate"]=>
        string(35) "SMTP Error: Could not authenticate."
        ["from_failed"]=>
        string(35) "The following From address failed: "
        ["data_not_accepted"]=>
        string(30) "SMTP Error: Data not accepted."
        ["recipients_failed"]=>
        string(56) "SMTP Error: The following SMTP Error: Data not accepted."
        ["connect_host"]=>
        string(43) "SMTP Error: Could not connect to SMTP host."
        ["file_access"]=>
        string(23) "Could not access file: "
        ["file_open"]=>
        string(33) "File Error: Could not open file: "
        ["encoding"]=>
        string(18) "Unknown encoding: "
        ["signing"]=>
        string(15) "Signing Error: "
      }
      ["error_count"]=>
      int(1)
      ["LE"]=>
      string(1) "
    "
      ["sign_cert_file"]=>
      string(0) ""
      ["sign_key_file"]=>
      string(0) ""
      ["sign_key_pass"]=>
      string(0) ""
    }
    
    The E-mail debugging output is shown below:
    
    See FAQ
    
    SMTP -> ERROR: Failed to connect to server: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.
     (10060)
  9. GeoffreyG
    Member
    Posted 3 years ago #

    Hello ibrar0,

    Hmm, I'm not sure what the problem is here, but the error message at the bottom:
    "SMTP -> ERROR: Failed to connect to server: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.
    (10060)"

    suggests a connection problem to the server. A couple of things I might try:

    1. Verify all of the setting in the plugin are exactly as I stated above (when I used different combinations of settings, the plugin always failed for me).
    2. Check your user name and password settings and make sure they work to login into: https://login.secureserver.net/index.php. If you can't login to that GoDaddy email server, then this is the problem and you will need to get the proper settings from GoDaddy.
    3. This is kind of a long shot, but try using "relay-hosting.secureserver.net" as the "SMTP Host" setting in the plugin.

    Anyway, I hope this helps and good luck!

    GeoffreyG
    http://www.ImagineThought.com

  10. sigdd
    Member
    Posted 3 years ago #

    Just unsubscribing from this thread. Ignore! GeoffreyG - thanks, again! :)

Topic Closed

This topic has been closed to new replies.

About this Topic