WordPress.org

Ready to get started?Download WordPress

Forums

Smilies screwup (9 posts)

  1. nekkidfish
    Member
    Posted 10 years ago #

    Okay ... I'm starting a new thread because this is smilies related, and I'm not sure what I did wrong.
    My blog index does come up, but my admin log in page does not. I get about 6 lines of errors that look like this:
    Warning: Cannot modify header information - headers already sent by (output started at /home/virtualw/public_html/blog/wp-config-extra.php:94) in /home/virtualw/public_html/blog/wp-login.php on line 254
    I added about 7 icon_smiliename.gif to the smilies directory, and then added them to the wp-config-extras.php file.
    I logged into my admin area, made post, used some of the new smilies, and all was good.
    However, I then went back and added one more 'icon_cherry.gif' to the smilies directory, and added it to the wp-config-extras.php file and then tried to log into my admin area and got the above errors. I didn't do anything different, but something obviously went amuck!
    As I said, my blog index page still comes up, but not the admin login.
    Any ideas? I've looked and even deleted that icon and the code, and I still cannot login.
    HUGz and thanks! Jules

  2. Mark (podz)
    Support Maven
    Posted 10 years ago #

    "Warning: Cannot modify header information - headers already sent" usually indicates whitespace.
    Check each file that you have altered, and check that there is no whitespace before or after the opening and closing tags.

  3. nekkidfish
    Member
    Posted 10 years ago #

    I'll go check again, but I think I've checked them like 5 times. BRB.
    Thanks and hugz! Jules

  4. nekkidfish
    Member
    Posted 10 years ago #

    Yup ... sure enough, there was like 5 extra empty lines before the ?>
    I wonder how those got in there?
    I gotta remember that in the future when I have troubles. This php thing is all new for me, and I'll have to remember that white space look-see when I have troubles, before I post here.
    Huge HUGz and thanks! Jules

  5. Mark (podz)
    Support Maven
    Posted 10 years ago #

    Excellent stuff !
    You could always use the free Crimson Editor.
    It highlights whitespace, and can be set to trim it, unlike Notepad.
    http://www.crimsoneditor.com/
    It looks prettier too :)

  6. aeryn
    Member
    Posted 10 years ago #

    On a Mac: would that be Bedit in place of Crimson? Can anyone suggest a text editor that does what Crimson do to show any white spaces? Thanks.

  7. nekkidfish
    Member
    Posted 10 years ago #

    ery kewl ... thanks for the link!! :D
    HUGz! Jules

  8. mpt
    Member
    Posted 10 years ago #

    In BBEdit Lite (and I assume in BBEdit too), you can open the "Text Options" dialog and choose "Show Spaces" and/or "Show Invisibles". These options are also available from the text options menu in the toolbar.

  9. aeryn
    Member
    Posted 10 years ago #

    Thanks, mpt, I use Bbedit & Lite. :)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.