WordPress.org

Ready to get started?Download WordPress

Forums

Smilies Generate Error in .71 RDF and RSS2 feed (7 posts)

  1. Paluei
    Member
    Posted 10 years ago #

    Why when i use emoticons/smilies (in version .71) my RDF or my RSS2 feed become errors ? anything to fix it rather to disable smilies on my blog ?

  2. Anonymous
    Unregistered
    Posted 10 years ago #

    You're seeing this in your RSS reader? It may just be the reader.
    Have you run your feed through the validator?
    http://aggregator.userland.com/validator
    http://feedvalidator.org/

  3. Paluei
    Member
    Posted 10 years ago #

    I'm Using IE 6.0 before i put smilies or if i not put any smilies or i disable smilies the RSS2 or RDF show normally but if not if i put smilies or if i enable the smilies. you can try installing WP .71 gold and see what i mean. I've try this with freshly *not modified* WP .71 gold and the result is same. here the link: http://blogtoni.com/wp/b2rss2.php or http://blogtoni.com/wp/b2rdf.php .
    It shows like this:
    An invalid character was found in text content. Error processing resource 'http://www.blogtoni.com/wp/b2rss2.php'. Line 43, Position 137
    <content:encoded><![CDATA[Heheh… utak-atik css hari ini <img src='http://blogtoni.com/wp/b2-img/smilies/icon_razz.gif' alt=':

  4. paulzag
    Member
    Posted 10 years ago #

    Your feed looks fine in FeedDemon 1.0beta5a -- the smilies show as :mad: :cry: and all the rest.
    Why would you be using IE to view the RSS feed? It isn't an aggregator. However my RSS feed http://www.wealthesteem.org/b2rss2.php renders in IE6 (but that's a pretty useless exercise).
    Note I'm using WP 0.72b2 and CVS. What version of WP are you using?
    As well as validating your feed as suggested by alexkingorg, try looking at your feed with an online aggregator like http://www.bloglines.com/ or http://www.mywireservice.com/

  5. Paluei
    Member
    Posted 10 years ago #

    Well thank you for suggestions, that's help me much.
    Actually i'm using WP 0.71 gold. But because theese errors *In my IE* i cannot check the validity of my CSS on http://jigsaw.w3.org/css-validator/validator?uri=http://www.blogtoni.com/wp/
    The errors says:
    Validator
    Error
    Target: http://www.blogtoni.com/wp/
    Please, validate your XML document first!
    Line 57
    Column 114
    The value of attribute "alt" must not contain the '<' character.

  6. Matt Mullenweg
    Troublemaker
    Posted 10 years ago #

    The new smilies code fixes this.

  7. Anonymous
    Unregistered
    Posted 10 years ago #

    a em strong code ul ol li blockquote

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.