WordPress.org

Ready to get started?Download WordPress

Forums

Cunjo: The Best Free Social Share Plugin
smarty error on update to latest version (7 posts)

  1. sparkleflavor
    Member
    Posted 7 months ago #

    Greetings awesome cunjo developers,
    Love what you're doing!

    I recently updated to to the latest cunjo version, and am now receiving the following error message where the share buttons should be.

    I uninstalled and reinstalled the plugin with the same error... example page here:
    http://sumchoices.com/technology-time-traveling/

    It looks like a permissions error, but I'm not clear which file I should be looking at.
    Appreciate any pointers you can provide!
    Thank you so much!!!!!
    Best Wishes,
    Amanda

    Fatal error: Uncaught exception 'SmartyException' with message 'unable to write file ./templates_c/wrt52a76dac0967d4.25156391' in /home/sumchoic/public_html/wp-content/plugins/share-social/Smarty-3.1.13/libs/sysplugins/smarty_internal_write_file.php:44 Stack trace: #0 /home/sumchoic/public_html/wp-content/plugins/share-social/Smarty-3.1.13/libs/sysplugins/smarty_internal_config.php(199): Smarty_Internal_Write_File::writeFile('./templates_c/3...', '<?php $_config_...', Object(Smarty)) #1 /home/sumchoic/public_html/wp-content/plugins/share-social/Smarty-3.1.13/libs/sysplugins/smarty_internal_config.php(214): Smarty_Internal_Config->compileConfigSource() #2 /home/sumchoic/public_html/wp-content/plugins/share-social/Smarty-3.1.13/libs/sysplugins/smarty_internal_data.php(285): Smarty_Internal_Config->loadConfigVars('EN') #3 /home/sumchoic/public_html/wp-content/plugins/share-social/constructor.php(114): Smarty_Internal_Data->configLoad('locale.conf', 'EN') #4 /home/sumchoic/public_html/wp-content/plugins/share-social/construct in /home/sumchoic/public_html/wp-content/plugins/share-social/Smarty-3.1.13/libs/sysplugins/smarty_internal_write_file.php on line 44

    http://wordpress.org/plugins/share-social/

  2. cunjo
    Member
    Plugin Author

    Posted 7 months ago #

    Hi, thank you for contacting us. Can you upgrade to version 2.2.2 and see if that fixes the issue. I added the option to disable/enable built-in cache from general settings.
    When you upgrade it should be disabled by default and you should leave it disabled and that should fix it. Because you have hosting write restrictions you will not be able to use the smarty cache for widgets because it tries to write a cache file within the plugin. If you will want to use this feature you will have to talk to your hosting company about file write permission and tell them you want to be able to write cache files using Smarty engine.

    Let me know if this upgrade to version 2.2.2 fixes your issue.

    Regards

  3. kina60
    Member
    Posted 7 months ago #

    Me too: version 2.2.3

  4. cunjo
    Member
    Plugin Author

    Posted 7 months ago #

    Hi, in version 2.2.3 on your cunjo general settings page you should find "Cache widgets" dropdown. Please make sure is set to No and save general settings again.

    Regards.

  5. ReadyToWrap
    Member
    Posted 7 months ago #

    I'm getting the same error and my "cache widgets" is set to "no".

    http://whatmusesme.com/double-chocolate-turtle-fudge/

  6. sparkleflavor
    Member
    Posted 7 months ago #

    Greetings again,

    I upgraded to 2.2.3 and am still getting the smarty "failed to write" errors.

    I checked out the database tables to verify if if the cache field was on or off, but I actually couldn't find the table for the "general settings" section. or cache

    Happy to contact my webhost as well -- just not sure what to ask them.

    Thanks so much!

  7. ReadyToWrap
    Member
    Posted 6 months ago #

    I posted a new thread here about the same error. After not getting response from cunjo here, on 12/19 I then sent in a support ticket with Cunjo via their website. They will not respond there either.

Reply

You must log in to post.

About this Plugin

About this Topic