Ready to get started?Download WordPress


Google Analytics Dashboard
Small bugfix suggestion, with code (1 post)

  1. ydubois
    Posted 7 months ago #

    Hi, great plugin!

    However, you should urlencode all $partial_uri variables in ga-lib.php . The reason for this is that some site URLs might contain the comma (,) character, which is accepted unencoded inside URLs by most browsers, and by WordPress itself in its pretty permalinks.

    However, the GA API does not allow the unencoded comma in the ga:pagePath= parameter (because the comma serves as parameter separator in the API call).

    I noticed other sites on the web using your plugin that have commas in their URLs and do spit out an error because of this. ( The actual error is "GDatainvalidParameterInvalid" )

    So please juste search/replace all occurence of . $partial_uri . by . urlencode( $partial_uri ) .

    Please consider including this very simple fix in your next release of this great plugin.

    Thanks a lot.



You must log in to post.

About this Plugin

About this Topic