WordPress.org

Ready to get started?Download WordPress

Forums

Slow wordpress page loading (4 posts)

  1. mackinder
    Member
    Posted 7 years ago #

    I am new to blogging, wordpress, everything.
    Installed wordpress on my website using my host's one-click option. Everything seems to work right with one exception: TOO SLOW!!
    Everything I click on, logged in or not, is very slow.
    I was reading under options/general how to give wordpress its own directory. Its kind of confusing though.
    My situation:
    - installed wp on mackinderrealestate.com/blog
    - want it to show up on main domain mackinderrealestate.com now
    - don't want to uninstall and re-install (unless necessary)
    - everything wordpress touches is very slow
    - other pages of my site are not slow (so not server problem)
    - Help!

  2. Samuel B
    moderator
    Posted 7 years ago #

    Give this a read:
    http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory
    If you're still not comfortable doing it:
    http://install4free.wordpress.com

  3. mackinder
    Member
    Posted 7 years ago #

    Thanks. I followed the instructions, but didn't find the .htaccess file noted in instruction #7. I searched all the directories on the server.
    Everything works now, but I didn't do the .htaccess copy. Am I going to have a problem later? Why no .htaccess file?

  4. Samuel B
    moderator
    Posted 7 years ago #

    You just need to create one.

    Open notepad
    press space once
    save the file as 'htaccess.txt'
    upload that to the blog's main directory
    rename it to .htaccess
    change it's permissions to 666.
    
    Than change the permalinks
    in your admin.

    After setting the permalink structure you want - change permissions on .htaccess to 644 for security.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags