WordPress.org

Ready to get started?Download WordPress

Forums

Slow the_content() (5 posts)

  1. macro
    Member
    Posted 9 years ago #

    I have been having this problem for a while now- since I don't know when, but only recently I've traced the slowness of my blog to the the_content() function.

    I have tried things like disabling the my-hacks.php file (which includes the call to phpGiggle), disabling all plugins which may affect the content, and switching themes. I have also recently installed the Prerender plugin, which has improved the speed of the page overall (I now call the_prerendered_content() in my template), but I do not believe it fixes the problem at its root, wherever it is. Before I installed the plugin, I was getting page render times at around 3-5 seconds on average. Now, the render times are usually around .8-2.5 seconds. I have modified a few php files in the wp-includes directory, but not with anything that would slow them down. I even tried replacing them with the original release files. I have 23 queries on a standard blog page, and the minimal 7 if I create a page only with wp-blog-header.php being included. This blog runs on WordPress 1.5 Strayhorn (stable).

    On the same webspace I have a few basic WordPress 1.2 installs (fairly unmodified) that have quick page renders, similar to your typical promised WordPress speed. That is, somewhere around 0.5-1 second.

    So, somewhere, the_content() is slowed down.

    You can see my blog at http://paxasiana.com -- it's slow, no?

    Any ideas?

  2. davidchait
    Member
    Posted 9 years ago #

    Disable plugins, try speed test, then post again... phpGiggle IS AWFUL, to start with... Anything which runs complex regexp cases repeatedly on the content block will slow you down.

    I saw load times between .45-.7 for your page, with a few spikes to 1.2-1.5. Depending on your plugins, and the load of the server you are on, that isn't too shabby...

    <2s constant isn't slow in my book. I've done extensive optimization/debugging of a number of sites, and it almost always came down to the plugins in use -- at some level.

    -d

  3. macro
    Member
    Posted 9 years ago #

    Disabling phpGiggle isn't really making a difference. The only plugins I have activated are Auto-hyperlink URLs, del.icio.us cached, Search Hilite, Markdown, Prerender, Spam Stopgap Extreme, and WP Statistics. I don't always get <2s times. Sometimes I will get more, perhaps three seconds. Thanks though.

  4. moshu
    Member
    Posted 9 years ago #

    See this thread
    http://wordpress.org/support/topic.php?id=26897#post-151595
    he was also complaining about being slow...

  5. macro
    Member
    Posted 9 years ago #

    Thanks for that. I disabled Spam Stopgap Extreme, and it did speeden things up a bit (at least noticeably). I am now trying Spam Karma to catch comment spam. We'll see how it goes.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.