WordPress.org

Ready to get started?Download WordPress

Forums

Slow page rendering (17 posts)

  1. s325607
    Member
    Posted 8 years ago #

    I have been browsing the support pages and have seen instances that are not exactly like mine so I'm starting a thread. Please direct me elsewhere if I've missed it.
    I recently(just today) noticed that my WP blog takes forever to load. This is just the actual public side of it, not the admin or "inside" of it. I'm running 1.5 and all the other standard stuff(PHP and MySQL on a mandrake box). I whittled the slowness to just this(WP's public face) by testing other sites running off the same apache server(which load as fast as before) as well as other PHP-based apps(phpBB, galery, etc.) and other mySQL-dependent apps(same as before). All the other sites/apps produce normal results, which is to say they respond within an acceptable 0.5-1.5 second timeframe(it's a slow box). The neat thing is that the guts of the WP install seem to proceed quite zipply. The admin area(when I can get to it) allows me to click on tabs, write and edit posts--everything on the admin side of things. When I have to go and actually VIEW the site it slows down. I haven't made any changes to the WP install or the box recently, and I'm pretty sure everythign else is fine because WP seems to be the only thing affected by it.

    Anyone ever heard of/seen this sort of thing?

    Cheers,
    Chuck

    p.s.- Feel free to take a look: http://nicholson.homelinux.com/wordpress
    (This will take forever to load. If you take off the /wordpress directory you can see the main page. Try the "forum" link if you want to see another PHP-MySQL based app running). If I'm missing something obvious, feel free to let me know.

  2. MichaelH
    Member
    Posted 8 years ago #

    Maybe start by deactivating plugins that might be causing the problem?

  3. spoofhound89
    Member
    Posted 8 years ago #

    I'm having this problem too. I deactivated plugins, removed recently added themes, deleted recently added code. Nothing works. My page takes forever to load and the WP admin panel is no better.

  4. miri
    Member
    Posted 8 years ago #

    I was having the same problem - the sidebar on the page would never finish rendering. Deactivating the WP-ShortStat plugin fixed the problem for me, though.

  5. spoofhound89
    Member
    Posted 8 years ago #

    I just deactivated that plugin again and my page loaded quickly. Don't know why it didn't work the first time.

  6. s325607
    Member
    Posted 8 years ago #

    WP-Shortstat did it. I had deactivated all the other plugins I could remember playing with over the last few days but this one was the culprit. Weird, I didn't do anything to it recently and it just now starts to drag ass?

    Weird I tell you. Anyway, all's well, Thanks all!

  7. pccw
    Member
    Posted 8 years ago #

    hey , i'd just wondering would it be "wordpress" attacked by something . it's because i have same problem in my 2 sites . use wordpress for admin also ..
    i'm now in scaring

  8. The reason why wp-shortstat is cause WordPress to run slow is that is uses a lookup service to determine the country for an IP which no longer responds.

  9. cpjolicoeur
    Member
    Posted 8 years ago #

    so, how do we fix this? can we hack the code to use another lookup service?

  10. jaseone
    Member
    Posted 8 years ago #

    If you want to keep wp-shortstat enabled but don't mind losing the country information you can comment out the following lines in the plugin by prefixing them with //

    $coinfo = @file('http://www.hostip.info/api/get.html?ip=' . $ip);
    $country_string = explode(':',$coinfo[0]);
    $country = trim($country_string[1]);

    like:
    //$coinfo = @file('http://www.hostip.info/api/get.html?ip=' . $ip);
    //$country_string = explode(':',$coinfo[0]);
    //$country = trim($country_string[1]);

    I'm trying to find an alternate service but there doesn't seem to be anything out there.

  11. cpjolicoeur
    Member
    Posted 8 years ago #

    I actually was just going to post the same thing. I just commented out the call to hostip.info and manually set

    $country = '(Private Address) (XX)';

    that will just set it as an inderterminable IP and not timeout. I'm looking as well for an alternative.

  12. citeewurkor
    Member
    Posted 8 years ago #

    I had the same problem. would this also cause RSS feeds to become broken? This happened to mine.

  13. citeewurkor
    Member
    Posted 8 years ago #

    I just implemented jasone's fix and my RSS feeds are working again, and my blog runs fast again.

  14. Joebar
    Member
    Posted 8 years ago #

    Good stuff guys, I was havin the same problem but wrote it off to my webhost moving some servers and data around. But it never got faster.

    Disabling worked for me also. I'll try the jasone fix tonite when I get home! Shortstat is too good to disable completely.

  15. citeewurkor
    Member
    Posted 8 years ago #

    Agreed, Joebar. Shortstat really is a useful plugin. If I need country of origin, I'll just hit AWstats with my host.

  16. cpjolicoeur
    Member
    Posted 8 years ago #

    looks like the hostip.info website is back up. i haven't tried pluggin it back into the shortstat code yet, but at least the side is active again.

    [EDIT]

    I just put the code back in, and there is no more timeout. Looks like the lookup to hostip.info is working again.

  17. jeremy
    Member
    Posted 8 years ago #

    Wonderful info guys, thanks. Haven't commented out the code yet, but sounds like it will work.

Topic Closed

This topic has been closed to new replies.

About this Topic