WordPress.org

Ready to get started?Download WordPress

Forums

"Slow Down Cowboy" Throttling Problems (2 posts)

  1. dponce80
    Member
    Posted 7 years ago #

    Hello. My site is OhGizmo.com. For the last three days, no one has been able to comment. This is because Akismet has caught around 320 comments... dated three months into the future. So now each time someone tries to make a legitimate comment, WP gives the "You can only comment once every 15 seconds. Slow down cowboy." error.

    I have tried getting Akismet to delete these spams, but it's unable to. Every time I press "delete", nothing happens. The only way I am able to delete these posts is by manually going into the db, and deleting them. But even if I do this, how do I know it wont happen again? How can I fix this?

  2. Samuel Wood (Otto)
    Tech Ninja
    Posted 7 years ago #

    You can disable the comment throttling by adding this to your theme's functions.php file:
    remove_filter('comment_flood_filter', 'wp_throttle_comment_flood', 10, 3);

    As for preventing it from happening again, well, first you need to figure out how it happened in the first place. The comment time is something it actually gets from your server, not from the user. How did your server's clock get off by 3 months?

Topic Closed

This topic has been closed to new replies.

About this Topic